# FMS 19.2 Crashed, now JDBC has a File Damaged Error

**URL:** <https://the.fmsoup.org/t/fms-19-2-crashed-now-jdbc-has-a-file-damaged-error/3211>\
**Category:** Questions\
**Tags:** community\
**Created:** [November 19, 2022, 3:40pm UTC](https://the.fmsoup.org/t/fms-19-2-crashed-now-jdbc-has-a-file-damaged-error/3211 "2022-11-19T15:40:57Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![OliverBarrett](https://avatars.discourse-cdn.com/v4/letter/o/f19dbf/32.png) [@OliverBarrett](https://the.fmsoup.org/u/OliverBarrett)\
**Post date:** [November 19, 2022, 3:40pm UTC](https://the.fmsoup.org/t/fms-19-2-crashed-now-jdbc-has-a-file-damaged-error/3211/1 "2022-11-19T15:40:57Z")

</div>

My client's AWS FMS Service (19.2) crashed yesterday.

Now, we're getting this error below for any SQL (SELECT, INSERT, ...).

**[FileMaker][FileMaker JDBC] (805): File is damaged, use recover**

A basic ExecuteSQL seems to work, however. At least one I tried.

Weird.

What's the best approach to fix this kind of problem (I've never used "recover").

Thanks.

---

<div class="post-metadata">

**Author:** ![Torsten](https://yyz2.discourse-cdn.com/flex030/user_avatar/the.fmsoup.org/torsten/32/1574_2.png) [@Torsten](https://the.fmsoup.org/u/Torsten)\
**Post date:** [November 19, 2022, 6:48pm UTC](https://the.fmsoup.org/t/fms-19-2-crashed-now-jdbc-has-a-file-damaged-error/3211/2 "2022-11-19T18:48:24Z")

</div>

If available, use a backup. Recovery is the second best option.

---

<div class="post-metadata">

**Author:** ![OliverBarrett](https://avatars.discourse-cdn.com/v4/letter/o/f19dbf/32.png) [@OliverBarrett](https://the.fmsoup.org/u/OliverBarrett)\
**Post date:** [November 19, 2022, 7:40pm UTC](https://the.fmsoup.org/t/fms-19-2-crashed-now-jdbc-has-a-file-damaged-error/3211/3 "2022-11-19T19:40:30Z")

</div>

Just got this fixed.

**What fixed it was just stopping and starting xDBC in the FMS Console.** The client tried about a dozen backups so we believed the problem lay elsewhere.

Thanks!

---

<div class="post-metadata">

**Author:** ![Torsten](https://yyz2.discourse-cdn.com/flex030/user_avatar/the.fmsoup.org/torsten/32/1574_2.png) [@Torsten](https://the.fmsoup.org/u/Torsten)\
**Post date:** [November 20, 2022, 8:10am UTC](https://the.fmsoup.org/t/fms-19-2-crashed-now-jdbc-has-a-file-damaged-error/3211/4 "2022-11-20T08:10:23Z")

</div>

Good news that your client got it fixed without recovery.  
The message

> **[FileMaker][FileMaker JDBC] (805): File is damaged, use recover**

does not seem to be pointing at the real issue in the case you described and is rather misleading. This could be improved.

---

<div class="post-metadata">

**Author:** ![OliverBarrett](https://avatars.discourse-cdn.com/v4/letter/o/f19dbf/32.png) [@OliverBarrett](https://the.fmsoup.org/u/OliverBarrett)\
**Post date:** [November 20, 2022, 12:37pm UTC](https://the.fmsoup.org/t/fms-19-2-crashed-now-jdbc-has-a-file-damaged-error/3211/5 "2022-11-20T12:37:33Z")

</div>

Yes, I agree -- the error returned does not indicate the actual problem.

FMS' stability seems very fragile.

These unhelpful error messages are a Claris issue!

All my code does is return the error FMP/S returns to it. This was the same error regardless of the approach used to access the database (either a third-party query tool like Data Grip, or programmatic Java code.)

At least the error text wasn't the usual FMP "?".

LOL

---

<div class="post-metadata">

**Author:** ![JasonMark](https://avatars.discourse-cdn.com/v4/letter/j/a9adbd/32.png) [@JasonMark](https://the.fmsoup.org/u/JasonMark)\
**Post date:** [November 28, 2022, 4:00pm UTC](https://the.fmsoup.org/t/fms-19-2-crashed-now-jdbc-has-a-file-damaged-error/3211/6 "2022-11-28T16:00:31Z")

</div>

FWIW I'm pretty sure I read that the latest FMP and FMP server have the ability to recover from the 19.2 lockout bug... not sure if that's what you got or not, but it's possible restarting triggered whatever script checks for the error and fixes it. I added a script to all my clients that turns off the menu on Filemaker 19.2 clients since going into the preferences can corrupt the database.
