XLSX Import Versions

Has anyone found what XLSX versions are supported for an FM19 import? I get a strange message, but can't find any information about supported versions. But maybe the error is simply misleading.
(I can try to create the screenshot in english if it helps).

Bildschirmfoto 2023-09-26 um 12.33.29

PS: IMHO, having 2 consecutive slashes in a path is absolutely legal, but FM does not accept it.

Bildschirmfoto 2023-09-26 um 15.04.07

Like you said, the German states that the version isn't supported. Very odd.

XLSX is the version. You shouldn't need to drill down from there.

There are other ways to get Excel data into FileMaker like a no-code platform like Zapier or a high-code platform like Java (POI).

The test was with FM19. The same test with FM20 in English gives the same result (ignore the $$BFS...)

Yep, I understood the German (keine Übersetzung nötig). :slight_smile:

XLSX is the current version of Excel so I'm really curious what others say.

Are you creating the XLSX in Office 365 or another environment like LIbreOffice or maybe even output from some third-party software?

Did you try another XLSX file?

What is the file type setting in the import records script step?

It's Excel Workbooks
Bildschirmfoto 2023-09-26 um 16.41.31

The output is from a 3rd party software.
BTW: Importing it via File -> Import Records works with this same file (used it to create the target table in the first place).
Opened it with MS Excel, made some change and did "save as...". Same result.

It works with both FM19 and FM20 if I work from another computer!

I have a colleague, who, within the last year, ran into a similar message about "wrong Excel version" when doing an import. My suspicion was always that the error message was incorrect, and that he was actually running into some sort of condition whereby FMP just wasn't able to find or access the file at the target path. I just pinged him to see if he could remind me of the resolution, but he does not recall.

I mention this because some of the symptoms mentioned in this thread also suggest to me that it could be more a question about whether the file can be located/accessed during the import records script step, rather than a conflict with a file version. No guarantees, though -- this is just speculation, and not with a whole lot of substantiation.

1 Like

I would try to get rid of the underscore in the filename, not per se but because of the position just before the dot of the file extension...

If none of these suggestions solve the problem, I'd be inclined to take a 365-generated Excel file that you can verify "works" in this situation and compare it using a byte editor to an "identical" file generated by the third-party software. These XLSX, DOCX, PPTX files are all basically zip files, but perhaps the issue is right in the file header.

It works on 2 computers (Ventura 13.5.2 and Ventura 13.6), both FM19 and FM20.
It doesn't work on the 3rd computer where I programmed it (Ventura 13.6), both FM19 and FM20.
FileMaker versions are the same on all clients.
I'll stop for the moment, maybe I'll try to compare some library directories.

Please post back with updates.

1 Like
  • The libraries look OK, still no idea what goes wrong on computer 3
  • Changed the script to run on server as intended from the start (PSOS). For this to work, I had to copy the file via script from a "public" server directory to one of the predefined directories (Paths in server-side scripts).
  • At first, "import records" returned status 0, but imported nothing.
  • changing the file mode from "--wsrwsr-t" to "-rw-rw-rw-" solved this problem, too. That means, even though FMS had read rights as group, it didn't import anything, but returned OK.

See what @ssh had to say about that in this thread How to schedule an email with Excel output of records from a table records in FMS? - #9 by steve_ssh

1 Like

I have imported XLS and XLSX versions, from LibreOffice and Excel in all versions of Filemaker. They ONLY xlsx files that filed to import everytime, were the ones written by Numbers.

IMHO, Numbers is a pain. It creates HUGE ".numbers" files with no way I've ever found to configure it to create an XLSX by default. I try to avoid it.