FMS 19.2 Crashed, now JDBC has a File Damaged Error

My client's AWS FMS Service (19.2) crashed yesterday.

Now, we're getting this error below for any SQL (SELECT, INSERT, ...).

[FileMaker][FileMaker JDBC] (805): File is damaged, use recover

A basic ExecuteSQL seems to work, however. At least one I tried.


What's the best approach to fix this kind of problem (I've never used "recover").


If available, use a backup. Recovery is the second best option.

1 Like

Just got this fixed.

What fixed it was just stopping and starting xDBC in the FMS Console. The client tried about a dozen backups so we believed the problem lay elsewhere.


Good news that your client got it fixed without recovery.
The message

[FileMaker][FileMaker JDBC] (805): File is damaged, use recover

does not seem to be pointing at the real issue in the case you described and is rather misleading. This could be improved.


Yes, I agree -- the error returned does not indicate the actual problem.

FMS' stability seems very fragile.

These unhelpful error messages are a Claris issue!

All my code does is return the error FMP/S returns to it. This was the same error regardless of the approach used to access the database (either a third-party query tool like Data Grip, or programmatic Java code.)

At least the error text wasn't the usual FMP "?".



FWIW I'm pretty sure I read that the latest FMP and FMP server have the ability to recover from the 19.2 lockout bug... not sure if that's what you got or not, but it's possible restarting triggered whatever script checks for the error and fixes it. I added a script to all my clients that turns off the menu on Filemaker 19.2 clients since going into the preferences can corrupt the database.