Restored file from TimeMachine backup still marked as damaged?

Hello fellow members,

The other day I experienced a power cut. My ups is old and immediately cut the power to my Mac. Result: a damaged FM database. Upon re-opening FM responded I should use the recovery command. I did and the db was restored with 2 records missing, which I could re-create. The 2 missing records had unique keys, so that meant I had to reset counters, etc. But I have back-ups (Time Machine), which appeared easier to do.

So I restored my file from an hour before the power cut. FM reports the same issue: use recovery command. then I restored the file from the day before the event. Same issue.

What’s FM doing here? Does it keep something in memory indicating that a file is damaged or what? What can I best to to remedy this? Thanks in advance.

Are you running FMS or did you just happen to have the file open when the power went out?

We have found when working with VM and snapshot if the file was hosted the snapshot backup process corrupts the file. It makes me wonder if your Time Machine has the same issue.

What we do to solve this issue is we run a backup schedule in FileMaker Admin console and then restore the backup-ed file not the hosted file.

Thank you for your answer. No, not running the file on FMS. Just a single iMac with one user. I regularly quit FM so that TimeMachine backs up the unopened file.

Very odd. I work in windows environment and do not know much about TimeMachine. What you are describing seems very odd and not at all what I would expect. Hopefully others will be able to help more then I can.

I'm not entirely sure of how TimeMachine handles the process of backing up. However, there are some things you could do. First, I would quit FileMaker and clear the cache before opening the backup. There is a possibility that FileMaker is looking at the file you are opening, then thinking, "I've got that cached" and using the cache.

Thank you Malcolm. I quit FM. Restarted my iMac. Even renamed the restored file to be sure. No avail. I am now restoring my missing records by hand, so eventually I'll have a file with all my records. But this is a worrying event. If you cannot restore intact files from backups.

just to make one thing sure: Are older TM backups fine?

Then, it could be that this hourly TM-backup was just running after the power issue

Here, we got TM backups on every machine (excluding some dirs..) - but the main backup goes via FM Server to the local machine and then via ChronoSync to a NAS. My workstation Mac has also ChronoSync schedules active for local files, running a couple of times per day (not hourly)

I had the feeling that TM has sometimes some issues as well )-:

1 Like

Thank you Markus. My setup is less sophisticated than yours. I tried opening restored files from hours before the powers issue, and even from days before. Just to be sure but they all yield the same result: damaged file. No way that ALL my backed up files are corrupt. IMHO it must be some obscure cache or trigger in the FM app deciding the file is damaged.

Sorry if it has already been mentioned,

did you open one the damaged file on a different computer ? For that test you would have to get back the file form TM, copy it on a thumb drive for example and bring it to the other computer. Then copy it to that computer and open. If that works, then you know that the problems lies on your computer.

Note that Time Machine doesn't backup open files.

1 Like

It does not sound like you deleted the caches.

  • macOS: [User Account] -> Library -> Caches -> FileMaker -> DBCache
  • Windows: C:\Users[User Account]\AppData\Local\Temp\FileMaker\DBCache

Also v19.6 has a button in preferences to do the job.


Note that you should NEVER, NEVER, EVER backup an open database with ANY backup tool, except the one provided by the database vendor. Due to the transactional nature of databases, caching, and temp stores, ANY backup done of a live database - FM, Oracle, MySQL, Postgres, DB2, Informix, etc. etc. etc - WILL result in a high probability of a corrupt backup and potentially a corrupt live database to boot. I posted a SoliantConsulting blog article in another thread on this.

1 Like
  • What version of macOS are you running?
  • what format is your Time Machine Drive?

The reason these questions are important:

Recent versions of macOS and TimeMachine can use APFS snapshots (see for example Leveraging Snapshots on APFS Volumes | Carbon Copy Cloner | Bombich Software )

It is my belief that Time Machine, when using an APFS snapshot, can actually back up an open file, and do so without errors.

However, this only works if (A) you are running a recent macOS version, and (B) have reformatted your Time Machine drive to use APFS.