How to use FILE with INSERT FROM URL

I saw a similar posting on the FM forum and realized I have the exact same problem: I've never gotten INSERT FROM URL to work with "FILE" so I think I'm doing something wrong.

In my case, I have a simple INSERT FROM URL with this for the URL portion:

"file://" & Get(DesktopPath) & "myimage.jpg"

I get "Connection failed."

As the other poster wrote, I've also tried various combinations of "file:", but with no success. I could have missed it, but I could not find an actual INSERT FROM URL example in the FMP 19 help with "file".

This example is a regular FMP sample application, but I also read that the file protocol is not supported in WebDirect. Is that true or did I misunderstand that?

Thank you all for your help.


Hi Oliver

Welcome to the soup. Does this help: ClarisPKB

Kind regards


Thanks, but sadly, no.

"file:///MacSSD/Users/oliver/theimage.jpg" as the INSERT FROM URL "URL" still says:

"Connection failed".

Got it!

Just removed the "Volume" part and it worked.

Thank you so much!



There's a cool utility on the Mac (probably others on Windows) called PathFinder that, when you right click a file, it gives you several ways to get a path....including "URL".



@OliverBarrett Can you tell us what version of MacOS you are using and if you had to also grant disk access to the FileMaker application?

Thanks for sharing.

1 Like

What I often do when my first attempt at freehanding in an URL fails: I insert the file in question, as a reference, into a handy global container field. Then I invoke Data Viewer and ask to see GetAsText (that field) and compare that to what I was attempting to use as the URL

1 Like

Hello @Bobino

Mac OS: 11.2.1
Did not need to grant disk access to FileMaker.

The examples above work fine on Mac, but in Windows, I can't get the file reference URL to work.


Use PSOS on the Mac!

(Seems obvious now .... LOL)