Installing MacOS on an old MacBook unsuccessful [SOLVED]

Hello friends,

I am having issues with an old MacBook Pro mid-2014. I wanted to install Monterey, so I tried to create a bootable thumb drive but didn't succeed. The creation of a thumb drive was done on a different Mac.

Since the thumb drive was not created, I used the Restore OS X function that brought back Maverick :unamused:. I rapidly configured Maverick, skipping setting the apple ID process. Now that I want to set it, again I forgot the password. There is a link to click in this instance, but Safari can't connect to the secure site :rage:.

Googled a bit but couldn't find a solution. Thought that was because I have not registered the Mac, trie to, but Safari can't bla bla bla.

Does some one recall how to solve this issue on Maverick ?

Many thanks

You need to use the Apple website, in there links at the bottom of the page look for my account settings. Trigger a password reset and get that sorted out first. Good luck with the rest.


I reset the password, there was no other way to solve the issue as you said.

Regarding creating a bootable thumb drive, I did not succeed. I restored the Mac, and now I am stuck with Maverick. App stores state that there are no updates available :roll_eyes:. I will borrow a bootable thumb drive that installs High Sierra. Hope that I will be able to go Big Sur afterwards, it's the newest macOS officially compatible.

I will post back.


App Store will only show you current OS and maybe one back. If you downloaded OS via your ID you can look in your purchases area for them. Otherwise you have to go to the apple website. All the old OS are available, deeply hidden.

Oh, I forgot about that !

Booting the thumbdrive created to install High Sierra didn't work. Two selections have to be done:

  • Select the partition: I picked the the thumb drive
  • Select a Wi-Fi network: I picked mine and clicked the right arrow

Another page swipes from the right asking for the network key: I type it. click the right arrow: the segment wheel is displayed for some time and I am back to the preceding page.

Looks like the Mac can't connect to the Wi-Fi. I can only guess because no error is displayed on the screen. Before the battery was changed, the MacBook ran High Sierra top notch.

I set this aside for now, but will come back to it.

Boy am I happy !!!

Problem solved. Looking for solutions I went across a Redit thread where some suggested to use an App called Mist, see GitHub - ninxsoft/Mist: A Mac utility that automatically downloads macOS Firmwares / Installers.

This app lists Firmwares and Installers: Firmwares can be downloaded and Installers can be downloaded or used to create a bootable installer disk. And the creation is fully automated. Just click on the proper button for the macOS version needed and wait.

Even though the latest version is 0.9, I tried it. Search for Download near the bottom of the page and click on the releases page link.

I tried it and it failed during the erase drive phase. Yes it failed erasing an empty disk !!! But this time I had a real error message stating error -16888 happened. That brought me to guess the thumb drive was bad behaving. I used instead a 32G microSSD card, created the bootable installer successfully and installed Big Sur on my old MacBook Pro !!!

Those who need to create a bootable installer, use Mist, you will be happy to use it.


Interesting discovery. Software and hardware often take the blame for the failures of externals and connectors.

The misbehaving SSD can be returned to full function using SpinRite

1 Like