macOS 10.15 catalina

there are warnings ‘not to update to macOS Catalina’ on several on-line resources, including ‘Tidbits’ and the german ‘MacGadget’

So, let’s wait some weeks before going ‘catalina’

I can not remember of such suggestions in the past )-:

before using Catalina, make sure you are not using any 32bit app: they won’t work under Catalina.

For that reason alone, I suspect a fair number of users will stick to Mojave for a while more than other OSes of the previous releases.

1 Like

I wonder I Apple offers a scan of a Mac to get a list of 32bits apps installed. That would help someone decision.

The thing I dislike about macOS is that it insists so much to bring you to the latest version. A lot of users do the upgrade and then get into troubles. On Claris Community, you will find lots of threads reading “I upgraded to macOS aaa and now FileMaker bbb does not work”. If only there was a way to have macOS forget about notifications for the new versions :disappointed:. The only way I know is to use the Server app to control the distribution of upgrades.

1 Like

In your system report, under software → applications you can click on the 64-Bit column header to group the apps together (32bit in a group, 64bit in a group)

1 Like

Go to the Apple Menu, select “About this Mac” and then run a System Report. Under the Software heading you’ll find Applications. Select Applications and after a few seconds ( or a few minutes if you’re not using SSD ) you’ll see a list of all applications. There is a column labelled “64-bit (Intel)” with a yes/no value.

mmh, in my System Report, it says “Older Software” (Ältere Software). This lists all 32-bit apps.


I can!
For HighSierra 10.13.0, there was a general “Printing Bug” and a “Crash on launch” for MS Excel.
Hard to understand how this “Printing Bug” would show up again with Mojave 10.14.0.
Fair to mention that most of the issues got resolved with first update in mid November.

Did I mention those 27(!) Bug Reports I had to send in during HighSierra Beta period?!

I’m running High Sierra ( 10.13.6 ) Here’s the list that I see.

and this is what my Applications panel looks like.

1 Like

They changed the design with Mojave to a separated list “Older Software” which means “last warning”!

Type in Terminal:

sudo softwareupdate --ignore “macOS Catalina”


I kicked the can and upgraded a dev server (Mac Mini) to Catalina. So far, no issues observed. FMS is v18.0.3. Wouldn’t dare doing it on a production machine…

I’ve just been forced to update, as I’ve clients who have jumped in with both feet and, as I’ve had to loan our spare MacBook, I can’t help them resolve their problems without doing so. I’ve gone into this with my eyes wide open and I am already prepared to say goodbye to some favourite apps (but we have been warned about this for some time).

First thing, the most useful command I’ve run in Terminal is:
sudo spctl --master-disable
I now have ‘Anywhere’ back in ‘Allow apps downloaded from’ and I can load various FileMaker versions and all the extensions I need (every one previously blocked, clicking allow didn’t). Early days and I still haven’t tried to do any work as yet (if you do wish to use your Mac for work, I strongly suggest you don’t do as I’ve done).

I think Apple need to watch this again, obviously just caught up with Microsoft Vista.


To further the point:

25 57 30

1 Like


You got to be pretty technical, these days (Johnny Mnemonic, somewhere in the 90ies)

Now, we are one step beyond and I can see situations arriving where we will proceed in an ‘analog’ way again…

I’ve already had the situation where my scanner could not send documents to my computer

The ‘Venezuela Story’ serves also as a reminder on that somewhat danger road

@Malcolm Thanks for the tip. I run Mohave and have only 2 32bits applications: InkServer and quicklookid32, both from Apple. The first seems to be handwriting recognition and I guess the second one is the preview app, so these should be replaced in Catalina.

@Cecile I typed your command, will see in the next days if the notification is gone. The System Preferences still shows 1 under Software Updates though. Thanks for the tip.

1 Like

I just boldly upgraded my development server to Catalina. :sweat_smile:
Before the upgrade it was running FM Server 18.0.3 with macOS 10.13.6

FileMaker Server started without complaining, and even FileMaker Pro Advanced 16 that happened to be on that machine starts and runs.
Also tested our Froodware Contacts Plug-In and Froodware Calendar Plug-In.
Installer worked, with the ‘software not notarized’ message. Plug-Ins also worked. So far, so good…

1 Like

Did you de-install FMS first, than perform the Catalina-Update and then re-install FMS OR did you just run the macOS Catalina Update without touching FMS?

Since having the Allow apps downloaded from ‘Anywhere’ back things have been surprisingly smooth with Catalina so far, to the point I’m almost tempted to say I like it.

My beloved 32bit Clarify has had to be retired and we have Citrix Workspace issues, but that is partly down to a combination of Catalina certificates and the age of some of our servers.

The first inconvenient surprise was when I upgraded Shimo (for €58) to v5, which we’ve used to overcome the lack of PPtP in recent macOS versions and received the following message:

No warning on their website, no warning within their in-app purchase, hence we’ve some remote support issues to address now (returning to this later, as thought I’d already posted and have the refund confirmed already, so well done to Shimo).

However, boy am I struggling to get the 10.15 update released last night installed. Been trying for about 4 hours, gone back to extensions off, couldn’t download it and having finally got it downloading, it has been Preparing macOS 10.15 update ‘less than a minute remaining’ for I don’t know how long and not sure where to move next at the moment, but have seen similar reports for the initial installation and people suggesting leaving it overnight, so guess I will. Also got some problems downloading App Store updates. Shame, was going so well up until now.

1 Like

OK, got the technical answer to that, decided to disconnect the USB-C cable to disconnect the main display overnight and forgot the USB to Ethernet connector was in the hub, error message followed that the Mac needed to be connected to the Internet to do the update, the progress bar jumped to the end, a message that the Mac was ready to restart and following that, the update completed.

Not sure I’ll find this on any knowledge base, LOL.

1 Like

I had a backup and it being a testmachine anyway, I decided to just stop FM Server and click install. Would definitely not recommend that a ‘normal practice’ , though