iOS sdk peer to peer

Hi looking through all the posts here a great deal are out of my comfort zone so I apologise if this question has already been asked and I am being repetitive.

I have created an iOS filemaker app a bit of which occasionally needs to communicate with a filemaker pro advanced db using peer to peer communications (not server).

If I run it under iOS SDK 15 it works great but the new Xcode (11 and 12) is causing the barcode reader to malfunction. If I run it under iOS SDK 19 the barcode function works fine but the peer to peer fails.

If I run it in FMGo I get a dialog to turn on the host but I can't get this within iOS SDK - any ideas on how to solve this?


I am using a DNS to provide access but can't get a security certificate on it :frowning:

1 Like

This is not a direct answer (because I don't have one), but it's worth mentioning that peer-to-peer sharing is a deprecated feature: ClarisPKB

Is there any chance you can install fms locally to ditch peer-to-peer?

Thanks for looking at my question. Apart from a significant cost fms brings with it a load of other issues which I don’t really want. Yes it is deprecated but my solution worked fine in 15 till Xcode caused the barcode reader problem (it was working great up till then). Unfortunately because 15 won’t take plugins I can’t go down that route. Of course the other solution would be to find why the barcode reader problem arose with Xcode. It continued as a problem into 17 but there was a solution in 17 where you could at least use landscape for barcodes.

Can you create your own certificate? That may work.

Hmm that’s an interesting idea - do you have more information on how and how to attach it?

I'd google self-signed certificate. :grinning:

If you look at the picture of the response it says it can’t verify and offers to ignore the attempt to verify which is what I need - I’m not sure that a self signed certificate is going to be trusted nor can I see where to attach it to try it out. In the app I declare the domain name of the dns as an external link which worked fine in 15.

Any ideas as to where the self signed certificate would go to try it out?

I'm really shooting from the hip.

We might need someone who actually knows what they are talking about