OAuth 2.0(Gmail) Send Email is not supported in Web-Direct on FileMaker Cloud

Hi, I have a client who is using web-direct in their normal operation. They ask me to add a send email feature to their system. I tried to add that to the system. Since my client would like to send an email on behalf of their account so I explored OAuth 2.0(Google) which works on Pro, but it results in an error 1542 if Web Direct is used.

Not sure if anyone has faced/posted this issue before. Bear in mind when developing your solution.

Nice to know. Try sending the email via the server instead (via PSOS). It avoids WebDirect limitations.

I can't see 1542 in the list of error codes. Is that number coming from FileMaker?


A few comments on it here, @Malcolm

This web search produced several posts on the topic.

I did the search because, like you, I didn't find it documented in my "updated" list of FM error codes.

Error codes for Custom Web Publishing contain the 1542 number. They hid that well.

1 Like

I have tried to use PSOS. Same result if I remember correctly. I may go to gmail api as an alternative.

Thanks. My CF lacks 1541, 1542, and 1543. Adding them. :+1:t3: :pray:t3:

I don't believe it's necessary to call the script using PSOS. You must be using the oAuth or the SMTP options. Support for the Send Mail step in WebDirect is partial and there are a lot of "buts" described in the documentation.