Admin console (v16) won't open encryption password dialog

So I'm spinning up a new server for testing purposes. I copy over an encrypted file and I can't get it to open. It should pop up a dialog asking for the encryption password, but it just reverts to "closed" and logs that the "wrong encryption password was used" when I didn't use ANY password.

I made sure that pop ups weren't blocked in the Chrome browser that I'm using with the admin console and even tried "clear all the encryption passwords" to no avail.

Anyone got any ideas as to what I'm missing here?

Part of this was set up for me by another member of the team so I don't know what means they used to install FileMaker Server etc so I may need to research some more details there if that's an issue.

A few questions to start with:

  1. How does the file behave locally? Can you open it?
  2. Is it asking you for the EAR password before opening?
  3. What if you copy the file, remove EAR and attempt to host that?
  4. What about hosting other files?

Sounds like someone had a file by the same file hosted previously and had opted to store the encryption key but that key is different than your current one?

From the command line try:
fmsadmin clearkey

and also look at the help for 'fmsadmin open' which lets you specify the encryption key, see if that makes it open the file


Replying to both in one post:
Yes it behaves normally for an encrypted file when I try to open in directly in FileMaker--it asks for an encryption key. I could remove the encryption as this is a test server, but then I'd also have to strip out a lot of sensitive data while retaining that which is needed for testing and that's what I'm trying to avoid here.

Wim, I tried the command line to clear the encryption key, but it didn't work.
I've tried to use FMSADMIN Open key ########
to open the file but something's not right with the syntax.

But I am going back to my coworker and finding out how they spun up this VM to see if there may be something in that which has the system trying to open the file with the wrong key.

the syntax would be
fmsadmin open --key

of course if either the file name or key name contains characters that the CLI doesn't like then make sure to use quotes around the file name or key.


It turned out that the needed step was to restart the server machine. Once we did that the appropriate dialog opened requesting the decryption key.


:grinning: Did you call Roy? "have you tried turning it off and turning it back on again?"