Filemaker 19 on Windows ARM

I'm trying to install Filemaker on Windows ARM (both the latest Windows 10 ARM64 and Windows 11 ARM64) and the installer chokes. I'm assuming it's just not supported (since that OS is still in Beta) but I wanted to check to see if anyone had luck installing it.

It worked for me on Windows 10.

But if the installer has trouble, maybe just try again.
or maybe try with Wifi off, clear temp files before, etc.

Ok good to know. I'm using the insider beta of ARM Windows on an M1 MacBook, what's your hardware? Is it also a Mac, or are there ARM windows machines out there?

Also, are you just using the standard Filemaker installer? I didn't see one for Windows ARM vs Windows Intel.

@JasonMark - the following has been taken from Windows 11 (if no luck search on this forum for Windows 11

"I will look at FMPA 15 again, as it was the last MDI version and there are still a few old Windows system where the customers haven’t invested in the upgrading as yet.

After getting Windows build 21277 with the x64 emulation, the key step to succeeding with the previously failed FileMaker installation attempts was to remove all Microsoft Visual C++ Redistributable entries in the Apps & Features list (in Control Panels), then install the preview version of the ARM64 C++ redistributable from:
https://aka.ms/arm64previewredist and install this.

Then install FileMaker Pro 19 as standard, allowing it to also install its standard Microsoft Visual C++ 2017 Redistributable (x64) 14.13.26020, so there are 2 entries in Apps & Features. We never install Bonjour, hence have not for this.

FileMaker 16 installed OK, but launching it initially resulted in ‘The application has been installed incorrectly or modified by another program Please run the installer to get a fresh copy of the application after determining the case’ but selecting ‘Modify’ for this in Apps & Features and ‘Repair’ sorted out whatever the problem was.

I’m just heading out of the office, but I”ve also postings on the Parallels Forum relating to this (somewhere).

Hope this helps in the meantime
Andy

This is helpful @AndyHibbs . Just wanted to confirm this is Windows 11 on ARM chips, not on Intel, right? Are you also working on an M1 Mac?

Today I installed Parallels with a freshly download Windows 11 insider build.
And installed FileMaker 19.3 there. Works well.

Except that desktop icon doesn't get created by installer.

OK thanks. I just did the same and the alerts that come up for installation are blank and then when I click it just closes. I'll try again from scratch. I didn't want to beat my head against the wall if Filemaker was Intel-only for Windows...

Hi @JasonMark

I was initially working off a 13” M1 MacBook Pro on Parallels v16 and Windows 10 for Arm insider edition when I posted the above. I had very similar problems to you and had to research and test extensively to get things to work.

I’m now on Parallels v17, Windows 11 for Arm, which came as part of the insider version and on a 14” M1 Pro MacBook Pro

I’m currently using Windows 11 for all my workspace streamed copies of FileMaker Pro, due to a problem with macOS and/or Microsoft Desktop Remote and the beta versions.

Good luck
Andy

Got it to work. Thank you all!

In case someone else has similar problems here's what I did to get Filemaker to run on an M1 Mac using Parallels and ARM.

  1. Went to Settings / Apps and Features and confirmed I didn't already have a C++ library installed (if I did I would have uninstalled).
  2. Installed this one that @AndyHibbs suggested: https://aka.ms/arm64previewredist
    This go me to the second screen, which had been blank before, but now I got an error about permissions
  3. shut down windows
  4. Parallels control center= Configured sharing from "none" to "Home folder only" and ran installer again
    Still had an error about a file not found after I ran this
  5. Manually found where the installer was extracted to (next to the file that I've been opening) and went in and found Setup.exe and ran it

Thank you @AndyHibbs and @MonkeybreadSoftware

2 Likes

@JasonMark I feel like you can mark your last post as a solution to the original question. That recap / walkthrough you wrote can be valuable for someone who is looking for a set of steps to try if they are dealing with the same situation.

Thanks missed that.

This worked for me, too! Thanks!