Windows 11

Having been running Windows Insider Preview ARM64 in Parallels 16 on my M1 MacBook Pro for some months now, I’ve repeatedly mentioned how impressive this has been in terms of performance and allowing me to run most versions of FileMaker backwards to v15 Advanced to support those clients who have not yet updated to v19.

Yesterday, I was taken slightly by surprise when the Windows update and subsequent restart resulted in the upgrade to Windows 11. I’m pleased to report that so far, so good and even FileMaker Pro 16 Advanced is now running, which had given problems before. To be fair, I haven’t tried it for ages, so it is possible an earlier update resolved the problem.

My main tools being Office, FileMaker and Sequel Server Management Studio all appear to be running fine and I’ve used it today as part of a client’s FMP v15 to v19 upgrade.

I do have a snapshot where I can revert to the Windows 10 option, but so far I see no need. One of my colleagues has been running FileMaker within Windows 11 on a Surface Pro X and has had some rendering issues that appear like a pinprick through FileMaker to other running apps. I’ve not seen any of this behaviour as yet running within Parallels.

This has been installed for less than 48 hours, so early days. Today there was another update that has added new features and, no doubt, there will be plenty more updates to come..

Have a good weekend everyone.

Andy

5 Likes

Well, I am quite amazed, to say the least. Windows 11 is supposed to require TPM 2.0 as well as Secure Boot. Both my Windows computers, dating back to 2012, are not upgradable to Windows 11 :weary:.

And you were able to install and run Windows 11 on a M1 Mac ?!?. I guess that must be the Win 11 for ARM ? If so, do you know if the ARM version also need TPM and Secure Boot ?

Parallels seems to be miraculous !

They could just emulate the required chip. Store the secure data in a file on your Mac.

Seems to exist for QEMU already:
https://en.opensuse.org/Software_TPM_Emulator_For_QEMU

Excellent occasion to buy a Mac :wink:

Yes, but no. I mean an M1 Mac can run Windows ARM applications, but what about Intel applications ?!?

Even though Parallels, or any other, could emulate i86 Windows environment, that remains an emulator. Would any application run well in an emulator ? That's the $ 100,000.00 question :thinking:.

The funny thing about M1 is that they run most Intel apps faster than man other Intel Macs.
And you need a beefy Mac Pro or iMac Pro to be faster with Intel software. Amazing.

Anyway, on the M1 you would run ARM version of Windows, which would emulate Intel Windows apps as needed.

Absolutely Christian.

The interesting thing about Windows for Arm (10 or 11) is that you get 3 Program Folders as shown by the attached screenshot. Everything I’ve double clicked in each of the x86, 64bit and Arm folder has launched without problems.

I tend to use Parallels as a convenient extra, but am gradually trying to use it more to try to establish just how robust Windows for Arm is. But Christian has hit the nail on the head, it is stunningly fast on the first generation Apple Silicon. Who knows where this could go.

image

When I migrated to Apple hardware (MacBook Pro) about 10 years ago, I installed Parallels with Windows, too. The apps I mainly used in the Win environment where MS Office and MS Project.

Subsequently I replaced them:
MS Office (Win) -> MS Office (Mac)
MS Project (Win)-> Merlin (Mac)
MS Visio (Win) -> OmniGraffle (Mac)

and do not have Windows on my machine for several years now (kept a Win PC for FMP testing, though).

I understand there are many specific business apps that are only available on Win.
Which are the Win-only ones you need to keep?

Hi Torsten

There are 5 primary reasons for using Windows for us.:

  1. Supporting clients with older versions of FileMaker that will not run on MacOS, which is primarily v15 and v16

  2. Testing in a Windows environment, Windows users make up the bulk of our customers (v19.3 update, need I say more?)

  3. Running SQL Server Management Studio when migrating data from the many Microsoft SQL databases we have replaced with a FileMaker solution :+1:t6: :smiley:

  4. Testing our RemoteApp servers in a Windows environment, particularly as Microsoft have a habit of releasing Windows updates that break their own Remote Desktop technology.

  5. Integration with Windows only applications

Please note that we also run FileMaker Pro via workspaces on ChromeBooks, Android and Linux, so we also have that hardware for testing purposes.

Kind regards

Andy

2 Likes

Oops. And of course IOS

Last but not least :slightly_smiling_face:

Do you consider a virtualised Win/FMP installation to be a fully valid testbed for FPM on Win, or does it take a 'real' Win/FMP for that?

That is difficult to answer. However, the experience of each copy of Windows is dependent on the hardware and drivers needed, so the virtualisation is just a variation of this. In general I’d say yes, with caveats.

1 Like

This is getting very interesting :smiley:. But for that to work, the emulation on Windows ARM will need to be excellent. Hope Microsoft will be able to succeed.

1 Like

This is all very interesting. I have not yet installed parallels, with Windows, on my M1 MacBook as I was worried it would not be a proper test environment for FileMaker on Windows, but I am encouraged to do so now.

Having a Windows VM on my Mac is very convenient for development & testing. I am still going to run final tests on an actual Windows PC before roll-out, but it's much easier to work on one machine for development.

1 Like

I have a switch, so I can work on either without changing input hardware. But sometimes I catch myself trying to do a drag and drop or a copy paste from one screen to the other and curiously it doesn’t work :joy:

Camtasia Studio and Snagit from Techsmith have more capabilities and power on Windows.

Photoshop and Acrobat Pro: I have very old perpetual licenses (c3) for Windows that I hang on to because I don’t want to pay the hefty monthly fee for the once in a while that nothing else will do usage that I do.

1 Like

Hi Ben, I was hoping to get this to you earlier. This was taken from my post in January: My journey on the M1 - #82 by MonkeybreadSoftware

I hope this will help:

"I will look at FMPA 15 again, as it was the last MDI version and there are still a few old Windows system where the customers haven’t invested in the upgrading as yet.

After getting Windows build 21277 with the x64 emulation, the key step to succeeding with the previously failed FileMaker installation attempts was to remove all Microsoft Visual C++ Redistributable entries in the Apps & Features list (in Control Panels), then install the preview version of the ARM64 C++ redistributable from:
https://aka.ms/arm64previewredist and install this.

Then install FileMaker Pro 19 as standard, allowing it to also install its standard Microsoft Visual C++ 2017 Redistributable (x64) 14.13.26020, so there are 2 entries in Apps & Features. We never install Bonjour, hence have not for this.

FileMaker 16 installed OK, but launching it initially resulted in ‘The application has been installed incorrectly or modified by another program Please run the installer to get a fresh copy of the application after determining the case’ but selecting ‘Modify’ for this in Apps & Features and ‘Repair’ sorted out whatever the problem was.

I’ve a few utilities I rely on as well, such as S3 Browser which is worked straight away.

At the moment, I can’t believe the speed of it compared to my previous experience of Parallels, although I tended to opt for the less powerful MacBooks and MacBook Air in the past, so perhaps it was as quick on the Intel MacBook Pros?"

Thank you very much Andy. Maybe useful to other folks too.

I guess you saw my post, above, which I quickly deleted, because I found the answer to my main issue - I needed to run the filemaker installer in the files folder, not the setup file - ? (I am more a Mac than windows user) Anyhow it's working fine now.

FYI - this is a fresh install today - I installed Parallels desktop. Then followed the instructions, from Parallels, to install the preview version of Windows for ARM (it installed Windows 10)

At the moment, I can’t believe the speed of it ... perhaps it was as quick on the Intel MacBook Pros?

I have always had top-end MacBook Pros (intel) and I was always impressed at how fast Windows ran in Parallels Desktop, and it's much cheaper than buying a 2nd Windows Machine :slight_smile: but now it's screaming fast on the M1 :grin:

1 Like

My experience installing FileMaker Pro 19.3 for Windows on an M1 MacBook Pro in Parallels Desktop running Windows 10 (for ARM, Preview) - in case anyone is interested.

I started with the installer from claris on the Desktop. Double click to run. Got message that I had to install Visual Studios C++ Libraries. Did that. Tried again, then got message I have to install Edge WebView Runtime - did that. Tried again and got an error "this installation package could not be opened....etc." So I could not install FileMaker Pro.

Then I looked in the installer folder that had been created on the desktop, and in there in a sub-folder named "files" found "FileMaker Pro 19.msi" I ran this directly and FileMaker installed fine.

FileMaker Pro 19.3 is now working, but the installation was not straightforward. I guess this is because of the ARM Preview version of Windows?

It also seems like I need the x64 version of the Visual Studios C++ Libraries, vc_redist.x64.exe not the ARM version.
https://support.microsoft.com/en-us/topic/the-latest-supported-visual-c-downloads-2647da03-1eea-4433-9aff-95f26a218cc0

And I think also the x64 version of Edge WebView Runtime, not the ARM Version.
https://developer.microsoft.com/en-us/microsoft-edge/webview2/

anyhow it's working now!

UPDATE:
Continuing my installation story. I was wondering why I couldn't use the ARM libraries, it seemed to be the installer package that was complaining. I uninstalled everything and started again, this time installing the Arm Libraries for Visual Studios C++ and Edge WebView Runtime, then running FileMaker Pro 19.msi from the files folder of the installer package. FileMaker Pro seems to be running fine. No idea if this will cause issues later, but so far so good.

3 Likes