FMS all mixed up, can't share a file on the server

Hello all,

I have a case where I can't share a file on the server.

Computer; Mac mini Late 2014
macOS Monterey 12.6.319.6.1.145

I first had a file called, lets say File_1.fmp12 that was first open locally and then shared on the server, all went fine. For some reason, I renamed the file File_2.fmp12.

I then open the renamed file File_2.fmp12 by double-clicking it in the Finder, picked Use local version the file open fine. I then wanted to share it on the server, by selecting File > Sharing > Upload to host... and was told the file would be closed, and I clicked OK. The file was closed, the Upload to Host window open and immediately the Connection failed message was shown.

I open again open File_2.fmp2 using the Finder, but that time picked Use Hosted Version - hosted version, how is that possible ? Any way a file was open, but that was File_1.fmp12 :thinking:.

In the server console, I closed File_1.fmp12, then tried again to open File_2.fmp2 using the Finder, but that time picked and picking Use Hosted Version. Guess what, I was told that The file "File_1.fmp12 - File_2.fmp2" could not be opened (Fie closed by host)".

My guess is that although locally the file name is File_2.fmp2, inside it is still File_1.fmp12. I tried to rename it using the Developer Utilities, but that does not work.

How may I repair that situation ?


When you upload a file to a host, that information is stored in the file. This allows Claris to provide you with a question. Do you want to open the hosted version or the backup?

You know best. :person_cartwheeling:

There is a hashed key stored internally. It is a unique ID (UUID) for the file. Changing the file name isn't enough to make that key update. This is a good thing. If you have downloaded multiple backups you may have named them: "File_backup_1", "File_backup_2". They are all copies of that original file and carry the original UUID. When you open one of these files, you probably want to open them locally. But if you actually wanted to open the hosted file, then this is a good warning.

Of course, if you closed the file on the host, then it is closed on the host :person_shrugging:


Upload and open the file manually to the server (via ftp, Drop box, etc.). This circumvents the internal UUID issue. You will then be able to open both File_1 and File_2.

Local File_2.fmp12 is connected to hosted File_1.fmp12 because they share a common ID. If I rename the local file back to File_1.fmp12, then a human will not be lost.

Then how may I proceed to a "rename" in order for connected files to share the same name ? I thought that renaming under Developer Utilities serve that purpose. Could it be that the imbroglio is due to the fact that I changed the name of the local file after it has been shared ?

Which way would be the best to achieve my goal:

  1. Remove File_1.fmp12 from the server and then Share on Server File_2.fmp12

  2. Rename back File_2.fmp12 to File_1.fmp12 locally, copy it locally via the OS to a file named File_2.fmp12, use Developer Utilities so the name inside is the same as the file name and the share it on the server ?

  3. Rename back File_2.fmp12 to File_1.fmp12 locally, clone it locally keeping everything and name the clone File_2.fmp12, and then share it on the server ?


I try not to use this method in order not mess with access permissions.

Well, it seems that FMP and or FMS are stubborn. I have rename the local file back to File_1.fmp12, did a Save As (Copy) to File_2.fmp12 and tried to upload to the server and got No connection.

In the console, I removed File_1.fmp12, the file was sent to Removed by FMS. I still can't share on the server.

I trashed the contents of Removed_by_FMS, but no joy. Is the only way to rename the file to upload it manually ?


@planteg, are you able to load any other file? Is it only this file that will not load?

Excellent question. I created a new file from Assets, added a password to the Admin account and was not able to share, same message Connection failed. Where can I get more information about that connection issue ? Nothing is found in the Server's logs. Could there be something on FMP side ?

I use scp or Remote Desktop to transfer files. Then I’ll set permissions and start the file manually.

My experience of the FMS upload tool is like yours. Unexpected and unexplained failures occur, so I don’t use it.

And I thought it was the best way :-(. Since the file is on the server, I will use the Finder to copy it and set permissions.

Had same issue once and used a different user account where it worked ..

1 Like

I manually copied the file, set the permissions and open the database. It worked.

@bdbd looks like Uploading through FMP is not that safe. Thanks

Their may be different reasons the upload does not work.


I just searched for that thread as well ( Check the answers from Thomas Hahn.
It seems that the upload is somewhere blocked by macOS

There is no certificate, FMS is used to do some tests, I never had such issues in the past.

as stated earlier a new user account or attempt from second computer might circumvent the obstacle ..