Font issue when creating PDF from FileMaker

A client recently created a PDF from FileMaker where the text came out looking like so:
Screen Shot 2021-03-29 at 11.03.31 AM
That's just a normal paragraph of text when view in preview mode in FileMaker.

The client was using a custom font, and when I had them switch to Arial the problem was solved. Anyone have any idea what causes something like that and how to fix it? FileMaker Pro 19.2.2, still waiting to hear back about which OS. Edit: it's macOS

Font needs to be embedded in file when saving as pdf. It’s a setting in pdf preference.

That’s a nice Rorcharch test btw!


Hi Cecile- thanks for your reply. Forgive my ignorance, but what exactly do you mean 'embedded in file'? Is there a post or Claris article on that? Is the PDF preference in FileMaker or Acrobat or somewhere else? Thanks so much.

Acrobat Pro. Or the application of origin. For example, if you have a Word document and you save as pdf, you have the option to embed font. It makes for a larger file so unless keeping the custom font is necessary, changing for Helvetica is wiser.

Pdf can be saved as images, as formatted text or OCRed text and as text with native encoding. If the font used isn’t installed on the operating system, pdf viewers will take the closest match.

1 Like

1 Like

Thanks Cecile,

I read both articles. The font "Roboto" does appear to be embedded in the manner they recommend (i.e. Type 1 or TrueType and Embedded Subset):

Any thoughts? Thanks again for your help

I downloaded roboto on a test mac and created a doc from the same database. Everything worked fine. Looking at the properties in acrobat, the main difference I noticed is that the type is "TrueType" in my case:

I'm entering a meeting will check on you after. Just noticed that you are making the pdf from FM.

1 Like

The screenshot shows that you have used old Type 1 fonts. In the newer versions of macOS, these no longer work properly. Now you should use True Type or OTF fonts. These are the current fonts types.

That’s not a FileMaker issue:


Thanks so much Cecile and Mipiano! This is no doubt the solution, and I've given the client the info he needs to reinstall the newer version of the fonts. I'll update the thread if he reports back his success or failure. Edit: well this was confusing- looks like I asked the original question with an older account that I forgot I had? But yeah, that was me that asked the original question!

1 Like

Today I found out, that FontLab has an app for converting Type 1 Fonts into other formats: TransType.

So you don't have to buy fonts a second time.

1 Like

Ask @Malcolm to merge your Mac account with this one!