Some FileMaker Interesting PDF Issues

We’ve had a couple of challenging behaviours with FileMaker recently that I thought some may find of interest.

On an existing system still running in FileMaker 15, we experienced the Calibri problems reported here - FileMaker Community (English) (‘Calibri + unrecognizable character breaks FileMaker PDF Engine’).

It is very weird having the same field repeated on a layout, within the same context but one using the Calibri font and the other Verdana. An extra trailing character can be viewed within Verdana, but not within Calibri. Our problem has only just occurred on a report generated for an action list for a single user, hence we’ve spent some time understanding the problem until establishing the problem confirmed by the above link. The sad thing is that this was acknowledged 2-years ago and is still a problem from v15 (at least) through to v18 and appears to being caused by a null character (code = 0).

Most text displayed these days is controlled by hidden feature rich code (try replacing the .docx on a Word file with .zip in Windows and extract it to find out what is behind each icon displayed) and we believe the downward facing caret beside emails, telephone number, links, etc. is a player in this. We certainly won’t be allowing Calibri to be used again on a report and will be adding an OnObjectSave script trigger on fields typically being pasted into to remove these characters.

Secondly, we have another system running in FMPA v17 where we export a Word file from a container field, it is automatically converted (via a 3rd party system) to a PDF and reimported into another container field in the same record. We were trouble shooting some slow PDF creation (finally traced to network problems, not our system) and were introducing a scripted pause for varying seconds to check the Word file had been exported and the PDF file had been created before reimporting. However, although the script completed and the PDF imported, it also opened automatically on each user’s PC, which was a change of behaviour.

Replacing the pause by a loop that escaped after a specified count to replicate the same functionality did not open the PDF file, which is what we wanted.

We still cannot work out why a script that exports field contents, pauses before importing a file from the same location would then open the contents of the container field. We left the loop in place and all worked fine.


1 Like

Phil ModJunk did an amazing job when he maintained the bug database. Unfortunately this does not exist any more.
Considering that some bugs live long and prosper and that @release of a new version there is no comprehensive list of what has been fixed and what hasn’t been, I’d like to have something here like threads for confirmed bugs and community info about workarounds and confirmed fixes.
I will open a thread for collecting ideas how we could make this happen.

1 Like

I agree Torsten, Phil’s efforts were so appreciated.

It is interesting on the Calibri issue as we have always used Verdana, not sure how Calibri got selected for this report, it certainly wasn’t on purpose.

However, some of the data with the problem characters go back 2 years and the database design has remained static, so quite why it should suddenly become problematic now is a mystery.

Perhaps a dedicated ‘Bug Report’ area could be a reason why people will come to this forum? But then again, shouldn’t all of these go to the official community ‘Report a Problem’ area? Perhaps a ‘Workaround’ section, such as how to get around the lack of OnRecordExit script trigger (which I’ve just tried to boost with another reason for it in the official community) might be an idea?

A bug description with assorted workarounds and - if and when available - bug fix, has a useful lifespan of about 10 years. During this period the information should be readily available to developers. Access should be easy. This forum provides the groundwork for such a helpful developer tool.

Not sure this addresses your posting directly, but I’d take a look at Apache Tika. This little gem (FREE) library can convert just about ANY binary data to text. If you want a more structured approach to working with, say PDFs, you can take a look at the PDFBOx library.

Here are a couple examples: Java PDFBox Example - Read Text And Extract Image From PDF - KnpCode

Thanks fmpdude

We’ve no issues with PDF creation, we use a product called FolderMill, which works nicely. We were just checking a file that had been created was greater than zero bytes before importing into a container field.

Gotcha. You’re welcome. :slight_smile:

Is this on Windows? Because it reminds me of a behaviour i often saw in Ms Office, when I was developing in VBA or using some macros. Despite the path being specified in the code, the macro paused at selecting/opening the file.
It is so long ago I don’t recall the trigger. I vaguely remember that some user setting or the file being open or already associated with a process still running (sometimes even if the calling app seemed to be closed) an example of that, specifically problematic with Word is the dependencies between word, outlook and the file explorer. If a file