Text wraps automatically

I'm having trouble setting up text fields so that the text wraps without cutting off words.
The fact I can't find any solution or (worst) any question online makes me confuse.
I'm using last version of FM Pro.
when I set a field with a long text FM treats the text as a sequence of symbols, not as a sequence of words, I'm using it to write contracts so the thing is anoing a lot :hot_face:.
Thankyou in advance :slightly_smiling_face:

Hello @Massimo ,

can you please post a screen capture of what you see and tell us what is the OS and it's version.



Hello, Sorry for my delay and thank you.
Here a couple of examples of cutted words, in a field and in a text area and the FM version. The OS version is Monterey.
Thank you in advance

It should handle modern Italian, including the legal jargon. Any discrepancy is a bug.

Create a new file for testing. Make a layout with a merge text field. If you can reproduce the problem you have a bug in fmp. Otherwise you have a problem in your file.

1 Like

thank you Malcolm,
I apologize for my bad question. I was in rush. Sorry.
I followed your advice and created a new file by using the file contact suggested by FM in the "starter" of the window for opening a file.
As you can see I write in a field a text (this time in english) and it works perfect. The same text in a field (anyone) of my program doesn't work as weel. What should i do? Where can I find the trigger to set it weel?

I suspect that there is something in your style definition that is giving you this behaviour.

If it affects all of your text fields the problem maybe in the default edit box or the default text styles.

Test by adding a new layout and applying one of the built in themes to the layout, make a merge text block and fill it with Italian language.

1 Like

Hi everybody,
I found the solution. The problem was very easy to solve.
I'm secure I didn't explain properly the situation.
Just flag the appropriate tag in the file options. The explanation of this flag is not very clear in italian
, maybe in enghlis suts better.
Thank you everybody


Here are the File Options on a USA/English system - I'm pretty sure these are the defaults - I don't think I've ever changed any of these:

1 Like