Upgrade FDS → FMS?

Is it possible to start with FDS and later upgrade it to FMS?

Since the software itself is the same, as I understand it, I'm assuming that's just another license to buy and then apply. Not sure I'd get any credit for the FDS license amount paid if I upgraded to FMS in the same year, but just wondering what my options are.

FMS is the same whether you obtained it with a FDS, FBA or any other license type. You simply import the new license to change from one license type to another.

1 Like

Thanks ... Do you know if FMS works with two-year SSL or am I stuck with one year only?

Multi-year SSL certificates work.

thanks.

its so much "fun" to go through the cert process cutting that time by half is always good!

Adding a caveat... it works for now. LOL

1 Like

Trying to create a CSR, from this page:

Creating a certificate signing request, it says: " To create a certificate signing request, use the CLI command fmsadmin certificate create"

However, when I do that, I get this:

Normally when I create a CSR, I have to enter the company name and other fields.

Suggestions?

Never mind...found my notes from FMS 18 SSL install.

All good.

Looks like your command is missing the fqdn in the cli command. ( I know you figured this out, but thought others reading this may be curious )

1 Like

Sure.

You need to use this command:
fmsadmin certificate create --keyfilepass <password_here>

I used the $4.99 / year namecheap instantssl.

I noticed that for some reason (I've opened all ports and restarted FMS several times), the Master Machine will not start. Tried moving the toggle a dozen times, restarted AWS instance, etc.

What to try?

Fixed it. FMS running!

How did you fixed it ?

I had installed a JRE version (still JRE 11) that was just a tiny bit too recent. Also, the installer failed to install C++ distributable so it said I didn't have "permissions" (as administrator) to do the FMS install. I had to manually go out and install that first. So rather than being a 5 minute install it was more than 8 grueling hours. The log was useless with errors so high-level, they weren't actionable.

Hope I don't need to do that install again soon. Worst install experience ever.

The C++ distributable has hit a lot of us. Claris is aware of it and I'm confident that will get fixed soon.

1 Like

Thank you Josh!

Please load latest VS C++ runtime here:

https://support.microsoft.com/en-us/help/2977003/the-latest-supported-visual-c-downloads

You may better use that one as it brings libraries for several Visual Studio versions.

2 Likes

My install is done. I don't want to look at that again for a "while". :frowning: I'll keep your note handy, but hopefully, as @jormond said, C will fix the problem so this separate install is not necessary in the first place. Thanks.

FileMaker Server and Pro on Windows need the VS C++ runtime 2015, I think.
Eventually they will move to a newer one, 2017 or 2019.
The installer referenced there on the Microsoft page installs 2015, 2017 and 2019 at once.
It's just convenience and future proof.

This dependency should be managed by the FileMaker installer. Unless I'm doing C++ development, I don't want to have to worry about C++ dependencies. As @jormond said, C will fix this installer bug soon so it's something you don't have to think about (and shouldn't have to) to do an install of their product.