A VM software for MacOS

Hello all,

I have a MacBook Pro 15" mid-2014 running Big Sur, Intel CPU i7, 16G memory, 256 G SSD. I would like to run Windows 10 in a VM, if at all possible.

Someone suggested VirtualBox, which as you know is free. I downloaded it and finally created a Windows 10 machine. That was a nice occasion to remind me why I hated VirtualBox so much :rage:. I can't have the VM work at the built-in display resolution, not even on an Full HD external monitor. I tried to install the Additions - or whatever the name is - and did not succeed. What a painful software, and VirtualBox draws the battery a lot.

Is there a satisfying solution to create a VM with Windows 10 that will not exhaust my patience and that will not empty the battery in no time ? If not, I will do the work on a Windows computer.

Thanks for your inputs

For a Win VM on an Intel Mac you could try UTM.
From the general description:

On Intel Macs, x86/x64 operating system can be virtualized.


we got VMWare (macOS) and Parallels (Pro, macOS). Parallels Pro is needed here for some actions like creating 'initializers' (open up something, using terminal-scripts, etc. when starting up)
Parallels ist faster (at the moment)

Both are working under Intel Mac's, we got one version for testing on a M1 Mac with a specific version of Windows

Both are not freeware..

1 Like

I've been using VM Fusion (VMWare) for over a decade to run Windows on Mac. No issues. I haven't tried Windows 11, but with all the advertising and other annoying "features" MS is putting into 11, I will try to avoid it.
The VM Fusion Pro version was $199 and well worth it in my view.
VM Fusion is a perpetual license, which I prefer, unlike Parallels Pro.

1 Like

Get the additions sorted out. Without them you'll have a really awful experience.

Download them and put them into a location that is going to be accessible to your VM. When it starts it will provide you with a way to select the Additions. I recall that the tools provided in the VM window menus do that.

I've been using VirtualBox for a long time. I only use it for dev purposes, so I haven't needed it to be the fastest or the best. It has been reliable and trouble free.

1 Like

You are running a Mac with an Intel processor, therefore I would recommend to use VMWare-Fusion. That runs very nice and the VMWare-tools work perfectly.
Parallels is good, but tries to integrate "seamless" out of the box and several keyboard-shortcuts in Windows don't work anymore. That is adaptable, but never a 100%.

If you would run a Mac with an ARM-processor VMWare-fusion is useless, because you can't get the VMWare-tools to work properly. So no folder-sharing en no copy and paste between MacOS and Windows. On an ARM-mac, you're better of using Parallels, because the clipbard integration works good, but there are problems with 'folder-sharing', I couldn't get it to work on my M1 and of coarse the not working shortcuts are annoying :face_with_raised_eyebrow:

Were you using version 13 Pro of VMFusion?

Malcolm, I tried real hard to achieve this. First succeeding to mount the Guest Additions has been complicated. I finally got it, not because of the documentation which is a piece of scrap: the .ISO file was added but under Not mounted :roll_eyes:. So I try this and that and that... and finally it was under mounted CDs.

Then I needed to start the VM at least 3 times because the the field to type my password was not displayed. Finally I was able to login.

I went to the CD's contents, launched a program that installed an .EXE file under \cert\ I launched the program and nothing showed up. That seems to be a program that install certificates.

And even though I asked to have the Start menu entries created, they were not.

You are lucky that you succeeded having VirtualBox working. I have tried enough and I will remove VirtualBox from my MacBook.

Torsten, this is my next trial, since VirtualBox was a real pain.

Yes, I used version 13. I think that is the only version that support the ARM processors. On Intel v13 runs great btw :slight_smile:

I’ve used Parallels for years, struggling with the poor performance of Intel processors, but it has always worked.

However, Apple Silicon has transformed my use of Parallels, which has now become a daily driver, as per FileMaker and Outlook on the Mac. It can load instantly, having been ‘suspended’ after last use, all (my required) apps, including FileMaker work very well on it, it is fast and it works seamlessly with the Mac Finder. It is also heavily used for Teams and Zoom meeting, where just sharing the Windows 11 window overcomes all the restrictions of sharing windows within these apps (a full 34” wide screen share is not always appreciated by the attendees).

I was a very early adopter of Parallels and my Windows installation includes all the Windows preview version components that was necessary at the time and I am getting a few redraw issues now, mostly dialog windows, which can be resolved with a small resize. I understand that Parallels have made the Windows 11 installation much easier to setup now, but it is worth pointing out that this is an x64 emulation on top of Windows for Arm, hence not all Windows software will work on it. Once purchased, the annual renewal for all upgrades is about £30/year.

Recommendation - if needing to use a VM, do whatever is necessary to obtain an Apple Silicon Mac, if not consider a AWS/Azure online instance and use RDP.