the fm soup

Connection issues since update to FMS 18.0.2

Since the update of a FMS installation from v18.01 to 18.0.2 I have the following issues:

  • admin console connection from external machine fails (‘Safari can’t connect to the server’)

  • upload to host fails (‘Connection failed’)

Server: Mac Mini, MacOS 10.14.6

External machine: Macbook Pro MacOS 10.14.6, FMPA 18.0.2

Launching hosted files on the same external machine works just fine.

What I tried:

  • switched off the server firewall, no change

I also updated a dev server from and to identical configurations and it does not have the issues.

Any ideas what could be the cause?

Hi Torsten

Are you using a purchased SSL certificate on the server? Are you using the FQDN or the IP address to connect?

Hi Andy
I am using the IP and the FM certificate that comes with FMS.

hopefully, there will be an update soon for fms

Hi Torsten, have a look at this to see if it is of any help: FileMaker Community (English)

Hi Andy, thanks for the link. I checked and the .pem files the thread talks about are web in place on my machine. I actually can connect to the server, see and launch .fmp12 files. Only the admin console access and file upload don’t work.

Hi Torsten, I have seen this once before, but on a Windows server (memory now starting to work). The problem was due to the web server (IIS), both file upload and admin console rely on this.

I suggest you have a look for something related to this on the Mac.

Hi Torsten,

did you check for antivirus quarantine on your client?

do you have a proxy that blocks 443 or does some re-routing?

just thinking…
Holger

I think the best way forward is to first use Terminal to check whether you can connect to both port 80 and 443 (telnet serveraddress 80 and telnet serveraddress 443).

If this fails, then that is your problem, the question is then why? It could be that the ports are available but the webserver isn’t functioning properly. Turning on WebDirect on the server should allow you to test whether the test page can be accessed.

Good luck.

Hi Andy, Holger
thank you for pointing in the direction of open ports. What I found on servers:

Prod: not listening on ports 80, 443, 16000

Dev: listening on ports 80, 443, 16000

Both machines are set up in identical manner, firewall turned off. No routing issue either, I can access both servers from within their respective subnets.

Turning on the firewall on prod server and allowing incoming connections i.a.w. FM technical recommendation doesn’t work either. Dev%20Server%20Allow%20Incoming%20Connections

I cannot connect via WD despite Dev Server telling that WPE is up and running.

Just rebooted the machine once, problems still there, twice - all is back to normal.

I have no idea why this fixed it.

Now, ‘sudo lsof -nP -i4TCP:$Port’ confirms that server is listening on ports 80, 443, 16000, too.

what is frightning me is I’ve seen this on Win Server 2016 hosting FMS 18.0.1 some weeks ago. Rebooted at least twice before plugins where recognized. I didn’t have difficulties with external access because I was connected and logged in remote, I did not see any activities on the plugin side, so did two reboots and out of the blue they showed in the console. Not much transparency…and not really convincing

but I have stalled any testing with FMS 18 for now, the one instance for testing had frequent crashes of the console that could only be solved restarting the console service via CLI

1 Like

We’ve installed a production Mac (18.01), development Mac (18.02) and development Windows (2012) v18 (18.0.1) servers so far and haven’t noticed any problems as yet.

On each install, including the v18.0.1 to 18.0.2 due to the javascript changes, we’ve totally uninstalled the previous version, renamed the FileMaker Server folder and reinstalled, then restored our schedules. We haven’t as yet had time to update a Windows Server to v18.0.2 as yet, but the Mac install went smoothly.

Neither have we played around with the startup restoration yet, leaving most things as standard. However, the production site isn’t a large installation and our development servers are not under a high load user wise.

Just out of curiosity: did you do the set up on virtual machines or on a usual server setup? My experience is related to virtual machines, running WinServer2016 on ESX, instances were set up from scratch and patched to date before installing FMS.

Since I’m doing this for a couple of years now and this was the first FMS release I encountered issues with I got a bit nervous. Setting up FMS as a clean install on a new machine usually gets me up and running in 20 min max.

Maybe the plugins not being recognized is related to new security inhancements, I’m used to copying MBS to the servers extension folder and it shows up in the console. Had to restart twice to get it bound to/registered by FMS.

The following day the FMS had stopped. Next reboot. The files were served, could be opened by the client but no console in the local browser, tried Edge, Explorer, Firefox, Chrome and remote Safari although that is blocked by the proxy and can’t work anyway. Another reboot. Console showed up. Next day no console again. At that point I dumped testing as being to early with a .0.1 release.

The other testing environment in general showed the same behaviour. Frequent crashes of the admin console service over several days, server managebable only via CLI. I didn’t test any API things… Stopped the testing at that client too.

For the plugin issue, I remember having read somewhere (don’t remember exactly where), that FMS is expecting it being done by using the ‘Install Plug-In File [ ]’ script step.But this only works on the FMPA (client side).

Unfortunately, the FMS admin console does not provide a means to update and install plugins on the server.

We’ve used server plug-ins sparingly, but always by manually dragging them into the Extensions folder in the FileMaker Server folder (ours are usually Windows virtual machines). Always remember the Mac’s complications of permissions when dragging anything into the FileMaker Folder within the Library folder.