FileMaker Server 19 under CentOS

a couple of weeks ago, I installed a vm with CentOS - to be ready for testing FMS19...

It is quite a long time ago since I was more or less familiar with 'terminals'...

So, here a short note on how to install FMS on CentOS for (macos) dummies

  • CentOS is available as a install-option if You got parallels desktop
  • You get the FMS19 installer with Your current update to FM19, copy that on the CentOS-VM
  • that installer can't be double-clicked to install
  • terminal... (has wrong keyboard mappings here, makes it a bit more complicated) use 'sudo yum install filemaker_server-19.0.1-22.x86_64.rpm' (with correct path.. and do not rely on the filename, maybe You get a newer one..). sudo needs the root-passwd..
  • so, installation goes flawless
  • the admin console won't launch after install, although a 'console-file' was created on the desktop
  • on CentOS here, only firefox is available as default, but firefox apparently is not supported
  • therefore, go to the google chrome site (google-search for chrome centos...) and get the installer, then install chrome via yum. The chrome-site has good examples for the terminal commands!
  • when the installation of chrome is finished, start the admin console (open the file with chrome!)
  • the admin-console will be configured to have access to it using admin/admin (account and passwd)
  • the last problem to solve, was getting the correct IP (depends on the VM..)
  • here we go!

I had to update/upgrade my server machines, they are not on the required macOS. Yesterday, I updated an older Mini to 10.13 - this will be a test machine for internal use.
On that machine, an older FMS is currently installed (will install FMS 18 on that).
-> that machine seems not as crispy as the CentOS VM - but more testing is needed for comparision!

5 Likes

Nice!

I noticed that CentOS is also available (version 6 and 7) with VM Fusion.

1 Like

Just as a thought: the point of using Linux as a server is to not install any desktop UI on it. It won't break any FMS functionality if you do but it means more updating and more used resources...

3 Likes

Yes, true. Everytime I try that, colleagues are telling me exactly this (-:

Therefore the quote 'for (macOS) dummies'

:sunglasses:

1 Like

You can also just download the Centos 7.7 ISO and drop it on VMWare for a new VM.

Works fine here. You may install the vm guest functions, so you can Drag & Drop the FileMaker Server rpm to the desktop.

Then install it via terminal with yum. This may download a few more packages.

For admin console, I use Google Chrome on the Mac. Would be nice if Claris fixes this for Firefox, so it works with the default browser.

3 Likes

That's great info, thanks!

one thing, I forgot:

Don't know why, but I could not upload files from a client, could not open the admin console on an other machine

ss -lptn
shows the listeners, wether port 443 nor 16000 was listed..

systemctl start com.filemaker.httpd.start.service
did the trick, afterwards ports 443 (needed for uploading files via filemaker client) and 16000 (etc) were listed

I copied manually (incl. chmod for accessrights) a somewhat bigger solution on cent fms and compared it to the older mini... CentOS with FMS19 is faster! As mentioned in the opening post, I will install FMS18 on that machine - should be faster than the current version of FMS

2 Likes

Version 7.8 of CentOS seems to also work.

1 Like

Here is a link to Claris support that should be relevant for this topic.

https://support.claris.com/s/article/FileMaker-Server-for-Linux-Developer-Preview-Information

3 Likes

Interesting - I haven't tried that yet with my install.
A few things it could be in CentOS :

  • Maybe look at SELinux
  • Maybe look at IPtables / other firewall software.
  • Could be lack of resources (RAM, CPU cores.. etc assigned to your VM) what is the size of the fmp12 file? Try uploading a dummy one, with hardly any data in it?

Has anyone tried running fms with CentOS under virtualization (Parallels, Fusion, Virtual Box) on Mac hardware? Wondering what the performance is like compared to standard Mac fms.

1 Like

centOS on a parallels VM here, hardware is a 6 core Mini. Runs quite fast

We have CentOS in VMWare here on Mac. Works well.

Is it as fast as running the standard Mac FMS?

I noticed some pre-built CentOS VMs for VM Fusion online.

I do not have any benchmarks yet, but it seems to run very good/fast. It's still a preview...

Does anyone know what to put here for CentOS-hosted FMS? I'm new to CentOS, so I may also need guidance on how to see what group my account belongs to and what syntax to use when writing that group into this field in admin console. Thanks!!

My goal is to not have to type my admin creds everytime I perform an action with fmsadmin

External Authentication is not working yet with the Linux preview.

4 Likes