FMS v 18.0.3 is out

FMS v18.0.3 is out. This seems to fix an issue with Apache web server. Hopefully, related issues like this one got fixed, too.

4 Likes

Just tried to install FMS v18.0.3 on a MacOS 10.14.6 dev server. The installer told me that FMS 18 is already installed and terminates.

It requires a full uninstall-new install cycle.

Relaunched the installer after a full uninstall. The installer then asked for customer data. I put the company name in. The installer complains that this is not a valid license. No - it is the company name! No place to insert a key or importing a license file.
At this point, to go ahead, select a trial license install. Otherwise the installer just quits.
Once the install is completed, import the license file.

Setting up a new server is lots of work for a simple service update. Confusing, out of context dialog ‘This is not a valid license’.

Addendum: restart the server twice after installing the java package of choice, i.o. to make remote access to the admin console work again.

Ouch. Wonder if it’s specific to your system particulars or for any case scenarios.

I must admit, I haven’t tried a single update since v18 server came out without a full FMS and Java uninstall - Mac or Windows.

I’m hoping this is a temporary thing due to the Java licensing issue and not the signs of things to come.

1 Like

I’ve never done a FMS “update”. It’s always a full uninstall, reinstall.

@jormond, @AndyHibbs, I have done the v18.0.1 to v18.0.2 update i.a.w. the update instruction.
It worked fine. I also understand why you prefer to un-install, install for service updates.
However, the update instructions given should match the installer’s behaviour.

1 Like

Agreed. I just know I’ve run into issues anytime I tried to patch. It’s easier just to back it up, uninstall, blow away the FileMaker Server folder, and run through the install process. 15 mins vs 2 hours trying to figure out why nothing is working.

3 Likes

Yesterdays I updated a production server (Mac) to FMS v18.0.3. It went nicely and all was fine after reboot.

2 Likes