How to upload a FileMaker FMP12 file to Ubuntu Linux?

How to you upload a file to Ubuntu Linux? So far, I only have a PEM file defined which lets me in to the command line. I can access the FMP console by using the URL for that.
I'm missing something in my setup, I guess: user name + password options?
Thanks for suggestions.

We use SFTP via SSH login.

1 Like

I got it working, thanks.

When I upload a file to /opt/FileMaker/FileMaker Server/Data/Databases, it doesn't show up in the FMS console in the databases tab.

Can you think of why that might be?

Once I get this problem solved, I'll get a custom SSL certificate and a reserved instance.


I would go for priviliges: just an ls -alh in the Databases directory and compare it to the Sample File...

1 Like

Great idea, but this is still strange.

In SSH command window /opt/FileMaker/FileMaker Server/Data/Databases, ls-lah doesn't show the file I uploaded at all.

Yet, looking at the Volume I mapped, the test file is there:


This file not showing up in the OS at the command prompt doesn't seem to have anything to do with FMS. I'm baffled at the moment...


Additional info:

I uploaded a text file to the user home folder and that file was visible in both the volume mapped drive and in terminal (SSH). Something strange (user error, me, probably) with the databases folder. No idea why the FMP12 file doesn't show up. Have tried stopping and starting the server, rebooting instance, etc.


can't you just upload via the client or is that forbidden because of a missing certificate?

Yes, uploading to HOST from FileMaker does work. I'll just do that instead. Weird behavior using the volume drive.

Next step....SSL.

Hope you have a good one!


like going with LetsEncrypt?

Just be sure to link to the correct webroot on your Ubuntu, that can become quite tricky :frowning:

SCP is another option.

1 Like

I made the mistake of setting up a self-signed certificate initially for testing. Then, although I was later able to create and import the real SSL certificate into FMS (Ubuntu) and all was happy there, trying to add the host to FileMaker's "Hosts" didn't work. It looked like something, somewhere, was still using the self-signed certificate -- even though FMS was happy with the new one -- and reported:


Now, I seem totally hosed.

No matter what I do, I cannot connect back to FMS. The browser is saying there is a certificate problem and there's nothing I can do about it.

Of course, I can access the server and remove files in the CStore folder, but it's totally unclear what I should do at this point since I can no longer get to the FMS Console.

This is a mess.

Thanks in advance for any suggestions.

I'm pretty sure you already rebooted your Ubuntu server a thousand times :sunglasses:

What does the lock icon in your FM files window title bar look like? Green or orange or red?

Do you have an A-record pointing to your Ubuntu servers name somewhere matching it to the machines IP? Otherwise I would think that lookup and matching certificate name to server name might not be working. DNS could be tricky. Also adding a DNS entry does need sometimes some hours to get published...

just some more cents thrown in :slightly_smiling_face:

You're the best! Thank you.
I got it all fixed up. After I re-re-re-re-re-re-installed Ubuntu (I think maybe 10 times in total) after each of my goofs, I think it's finally working now correctly.
I probably could have gotten the SSL fixed without yet another re-install, but I kept getting errors even after deleting the /opt/FileMaker folder and trying to just re-install FileMaker Server.

I have to now install Tomcat and make sure it comes up when the machine boots and buy another certificate for that. Then, it's time for a beer!

Thanks very much for you kind replies and suggestions -- they definitely helped! :slight_smile: