Issues with Image Scanner portion (loading plugin)

I copied some of the contents from "imagecapture dialog" and moved them into a script/layout that does not have like variables or form fields added. It worked with 2 scanners yesterday.

Screenshot 2023-10-31 at 1.19.28 PM

The problem is whenever I go and select a scanner, the select option doesn't un-grey. The scanner I am using is an Epson ES-300W.

Can someone chime in some unknowns that could cause this?

Welcome to the soup @spicergroupalemstrom!

Looks like you got the plug-in installed. The select button is from the dialog from Apple. I can only guess why it is not enabled.
Can you click anywhere to deselect and select again?

Or is the scanner currently in use by some other application?

e.g. you may want to quit Image Capture app (if open) and maybe restart FileMaker to try again.

If some app has a connection open for the scanner, it is exclusive, so no other app can open it. Even in FileMaker it can happen that you try to open it twice and second time fails.

The only way to select off is to bring the search field up, which takes the focus away of being selected. If I have two scanners installed I can choose between the two and they work as expected.

Does anything come to mind config wise, I can't see it, nothing is "trumping" configuration settings in this script. No $r or $p attributes in it.

The same thing happens solo from the example.

I'm wondering if it is a Sonoma + FMS Pro 19 bug.

Some how it resolved itself... dunno whats up, however I did leave filemaker closed for a short moment. perhaps it stayed cached.

I'm having a problem getting the image to show in the container that already exists. on line 6 of Scan dialog what is "Get(FileName); part of?

I figured it out, I didn't set the file options start initialization script to activate it. between cache and doing this, I believe this resolved the issue. Sorry.

Great, if you solved it.
Sounds maybe like I could add some automatic initialization, so the initialize function becomes obsolete.

1 Like

Hate to say it, but I populated like buttons, and the scripts onto an Andrew.fmp12 file. It is initialized on page load, it allows choice of scanner, but it does not show the scanner options when opening the scanner portion. Any guidance would be helpful. The code jives with the ImageScanner Dialog.fmp12 setup.

Sorry to keep nagging.

First question is always, whether you can quit FileMaker and start it again.
Just in case you opened two connections to the scanner.

If you open connection via script, you may not be able to use dialog at the same time (second connection).

Hello,

This doesn't appear to be the case. It's like its partially loading the fields. It wont even prepopulate the txt field with the type of scanner I'm using.

When I try to open the documents.fmp12 file that i moved Image capture dialog, dialogs to is still working fine.

Not sure what to mention here, outside of that it isn't loading entirely, and its an exact replica code for code of imagecapture dialog.fmp12 file.

I sent Christian a copy of the file, not sure if he's looked at it yet.

I looked on the file.

In extended privileges in security dialog, you miss the checkbox for fmplugin:

That is needed to trigger scripts.