Loosing modifications

Hello gang,

I am feeling insane, like loosing my mind. I work with FMP I worked yesterday on a current file, I modified a Layout, created a table, and added a Theme, etc. This morning the modified Layout ... is not modified anymore, and the added table is gone :hot_face:. These days it happens way too often. What the heck is happening ???

Looks like closing the file wipe out everything new.

My OS is Windows 10 22H2 with latest patches.

  • Are you using FMP only or a file hosted with FMS (FileMaker Server)?
  • if locallly via FMP only, my guess would be you have more than one copy of the file, and you are opening the wrong one...

I use only FMP, file is saved locally.

This could have been a possibility, that's why yesterday I added a label to the opening Layout and to the one I was editing, to make sure I was opening the right file. This morning these labels were all gone. I know this issue looks crazy, but since last week, I have this issue, right after Windows monthly update, a coincidence or not.

I thought the issue could be triggered when the file is closed, so this morning I closed the file a few times, but nothing was lost. As a test, I just open the file, and all is fine. I am having other issues with Button Bars, but this time the explanation may be standing about 15" from the monitor.

So still a mystery, and I am fed up with this situation. I will post back.

Thanks for your input !

Are you using Windows roaming user profiles within LAN setup?

No roaming user profile, no Windows Server involved.

did you use the new feature "Delete Cached Temp Files" by any chance?

No call to "Delete Cached Temp Files".

Can you search for *.fmp12 files with recent modification dates? The file manager may reveal copies.

Is the file stored on a local drive, a network drive, a cloud drive, or --worst of all-- in a dropbox folder?

For sure I can. And I checked the modification dates, and pick the one that was last modified yesterday. Modifications were gone. Today I changed the file extensions to .fmp12_ for all files but the one I was working on. This way i can open the only one «i work one.

The file I am working on is saved locally on the computer I work with, no server is used.

There should also be small size differences that correspond to the new objects. This isn't always accurate but it can be an indicator.

I you are still curious, I have a tool that will identify any changes between two files based on the DDR. If you want to generate DDR for each of the different files I could identify the differences in them.

Sure I am curious. I will save the file's changes rig now, close it and copy it in another directory. I will the create the DDR for both files and send them to you,

Thanks !

Any chance the file is in Dropbox?

The only place they could have been shadowed is in OneDrive, but they would have been in sync with my local drive: garbage here, garbage there !

Since then I have added what was missing, and up to know all is fine. A new scenario came to my mind, still thinking about it. I will be back soon to explain.

Dropbox doesn't erase files, it creates duplicates, if there are two versions of a file!

But this could be the right path: I once used a NAS System to sync my files and had the exact same issue with a file, that I had been working on: every change had gone! So maybe there is some other syncing process going on here!?

1 Like

adding to this I have strictly forbidden my runtime users doing their setup in a synched directory because at best it slows down the solution and at its worst it erases data or does not let users create new database entries - iCloud, OneDrive etc. behaving all the same

1 Like

Not so sure. If assumed newer file is on cloud and local copy closed it will overwrite local copy. Have seen it after time zone change and time out of sync …

Interesting, I know this is not recommended practice and I’d never recommend this to a client. However, I’ve been running my personal database files, including my daily used (all day) customer and timesheet file in iCloud without problems for years.

This allows me to quickly copy files to/from my iPad and IPhone Pros so I always have the latest information on me.

To repeat, not recommended, but it has worked great for me.

Here is my latest guess at explaining what happened.

This application will run on iPads. Instead of copying a version to test on Google Drive and then downloading it to my iPad, I simply shared the app on my PC, still available, and open it in FileMaker GO. In order to have the largest area, the Menubar and Toolbar are hidden. That means there is no way to close the app. Swiping FileMaker GO to close it unload FMGo, but that does not close the app, since if you open FMGo afterwards, you are brought in the app at the exact same place. Could that explain my issue, since when I closed the app on the PC, something had it still open ?

FileMaker is always working with a shadow copy of an open file. It periodically synchronises the shadow copy with the original "stored on disk" file. The how, why and when of this synch is only known to Claris engineers.

It is unusual, but always possible, for something to prevent FileMaker from synchronising the shadow with the original. That would create the sort of problem @planteg has seen.

Also, we do not know what effect this synch has on the stored file's metadata. For instance, say a bulk operation changes several records. This change is stored in the shadow copy and the time is noted. For some reason, the shadow copy does not update the original for several minutes. In that case, is the file metadata modified to reflect the earlier time? We don't know.

If you are working on file that is stored in a cloud synch'd folder then you have a different processes that is deciding when and how to synch the local copy with the remote copy. The how, why and when of this synch is only known to that company's engineers.

Now you have two completely different file synch tools running. Neither talk to each other. And there are three "active" copies of the file: shadow copy, local (original on disk) copy, and the remote copy. It's going to be like a shell and pea game. :smile:

You cannot work in layout mode on your iPad so that is a red herring.

What do you mean? Is it possible to share/serve a file from FileMaker on the PC to FileMaker Go on your iPad?