Windows - Unavailable 'Insert PDF' menu/contextual menu

This topic has been reported many times throughout the Internet, with the 'Insert PDF' menu greyed out both in the main menus and the contextual menu despite the container field being set to interactive content within Windows.

The acknowledged solution to this is to install Adobe Acrobat Reader DC and all's fine.

However, we had a problem earlier this week on a Windows 2019 RemoteApp server that was streaming both FileMaker Pro 19 and FileMaker Pro 15 (until we can finally migrate these few clients to version 19). We believe this could also happen on Windows 10 or 11, hence wanting to document the solution for future reference as we could find not find this particular solution on the web.

We'd uninstalled and reinstalled Adobe Reader, restarted and tried various other ideas, including setting up a new local single container field test database. All was fine with FileMaker 19 but FileMaker 15 continued to display the greyed out menu.

We have 7 of these streaming cloud servers consisting of Windows 2012, 2016 and this one was our second 2019 server. We have very strict procedures to ensure all servers are configured identically, but this was the first time we had this problem.

We finally resolved the problem by uninstalling the Adobe Reader 64-bit version and download and install the 32-bit version. After this, FMP v15 displayed the 'Insert PDF' menu and version 19 continued to do so. We will revisit this to see whether we can run both 64 and 32-bit versions on the server, but have to wait until weekends before we can do so.

Finding the 32-bit version of Adobe Acrobat Reader DC is via a link at the bottom of the Adobe download page, after which both the 64 and 32-bit versions are displayed using the filter fields as shown below


I hope this helps someone in the future avoid the amount of searching and testing that we had to do.

Kind regards
Andy

1 Like

Thanks @AndyHibbs for your info.
I would like to add: Whenever two applications are to talk to each other, both must be either 64-bit or both 32-bit. Otherwise it won't work!

Best regards
Udo

Thanks Udo

I agree with you, hence our surprise that we needed to install the 32-bit Adobe Reader to interact with the 64-bit FileMaker Pro v15.

Very unusual, but it is the solution that worked. We had scripts that were failing due to the menu unavailability, which is where we started troubleshooting from.

All the best
Andy

Was FM15 really installed as 64-bit? I would have thought, the 32-bit version was installed.

Yup, as per the attached, not in the x86 folder. I'm just glad it worked as it was interfering with the workflow at the time.

Likely an artifact of the 19.4 transition from the installed PDF viewer to the runtime EDGE PDF display engine. We ended up writing code to emulate prior actions and putting a button object to execute on each of the 320 layouts where containers fields were used to accommodate the change. MacOS behavior was unchanged......