Ventura 13.2 / FMS 19.6.3 Upgrade Gotchas

Yesterday I upgraded one of my M1 mac mini servers from macOS ventura 13.1 to 13.2, and also did the FileMaker Server 19.6.3 upgrade.

I ran into a bunch of problems.

  1. FileMaker seemed dead - no databases would open, scheduled scripts failing, eventually I figured out the problem: Additional database folder is invalid or could not be set. The solution was to go to my additional databases folder /Users/myUser/myFileMakerData/ in the Finder, get Info, authenticate, and manually add the FMSERVER user with read/write permissions, then "Apply to Enclosed Folders". I also had to do this all the way up the chain, to /Users/myUser/ folder. Somehow, either the Ventura or FMS updates had reset permissions during the install.
  2. Scheduled scripts reported as "Failed". In the FMS Admin page, I could select a scheduled script, click the button to Run it, see that it worked, but the status would show as "Failed". This appears to be a false alarm: if the last script step in a scheduled script has an error (such as a Find Records step that returned no results), that error status would propagate outwards so that the FMS admin would show the script as failed. This seems like a behavior change to me. In any case, the fix is simple: Adding these two lines to the very end of the script seems to solve the problems:
Set Error Capture [Off]
Exit Script ("")
  1. After fixing these issues, I thought all was good! I went to sleep, and then a few hours later, started getting SMSs that the server was down. The problem?

It looks like the Ventura 13.2 install reset the Energy Saver settings, so the server was simply going to sleep after 3 hours. (In Ventura, this is now hidden in System Settings / Displays Advanced).

Fortunately, although this is on a production server, it's one of the lowest-used ones, so nobody (but me) even noticed the outages.


Additional thoughts:

  1. For this mac mini server, I had also changed out the USBC to VGA dongle (from a generic brand to Apple brand). I suppose it's possible this change of monitors is what reset the "Prevent automatic sleeping..." setting? rather than the 13.1 to 13.2 upgrade?

  2. Even though the server was "asleep", I was still getting FileMakerServer emails warning me of script failures:

2023-02-06 03:17:19.304 -0800 Error 691 Schedule "ServerScheduledRobot" aborted; time limit exceeded or server stopped.

But, dear reader, you may ask: if the server was off, how could it be sending emails? I wonder this myself.

As far as I know, the Mac Mini M1 does not have any sort of "PowerNap" feature.

Maybe the server was in fact waking up occasionally, sending an email, then falling back to sleep?


On the positive side: 24 hours later, and after telling the M1 Mini that "sleep is not an option" all is good again.

On the negative side, the FMS upgrades are still pretty awful though:

  • the Admin console web page tells you an upgrade is needed, but doesn't tell you how to get it
  • you have to remember your Claris download URL and get the download from there, but...
  • the FMS installer immediatly complains "FileMaker is still running" and then provides no hints about how to do the upgrade
  • the answer is to go to another URL to find the ReadMe for FMS installer updates, and read the hints. The answer seems to be:
    sudo launchctl stop com.FileMaker.fms
    however, if you try the install, it fails (sometimes)
  • the real answer seems to be
    sudo launchctl stop com.FileMaker.fms
    wait some amount of time (not specified) until all the services have stopped
    then try the installer

Nerver declare victory!

LIterally 2 hours after I posted that last message, I started getting SMS warnings that the server was down. I checked on my Apple Remote Desktop app, and it showed the server as "Sleeping"

I wake up the server, looked at System Preferences / Displays / Advanced and guess what I see:

Prevent automatic sleeping when the display is off was turned OFF again!

In fact, to test it out, I tried clicking it on (which worked) and then clicked it off again, and the click does nothing.

It seems like there's some new macOS Ventura bug with this feature - either the feature itself no longer works, or it resets itself, or the UI is not showing the proper setting state. Sigh.

Any update on this, @xochi ?
Did you figure out how to get your macOS Ventura FileMaker Server Mac to not go to sleep? Did Apple make a fix in a Ventura update?

I did get it to work normally after a while; I'm not sure what I did, but some combination of Restarting the server, updating to 13.2.1, and double checking that the Prevent automatic sleeping when the display is off setting was set seems to have done it. The server has 11 days uptime so far and is doing fine.

1 Like

It has been SOP for the FMS installer to reset file permissions, and reset the fmsadmin group, on every install or update. Probably often a good thing, but this might be another case of that causing problems, although I haven't seen it break the permissions to the database folders in the way you mention.

The unexpected powering down is classic Power Nap behavior. Certain actions can cause the system to wake back up, including FMS. To get the power/energy saver settings to stick I've sometimes had to reset the system's PRAM, appears to be an issue with certain hardware where these setting don't get saved correctly.


Great to see you here, @sibrcode !

1 Like

Alternatively, you can caffeinate your Mac through the command line or an app like Theine.

As far as I know, Mac Mini's don't have Power Nap, so that's not relevant for me as I'm using a M1 Mini for the server.

Here's what the settings look like in macOS 13.2.1:

M1 Mini: Energy Saver Pane

Intel i9 Macbook Pro: Battery Pane / Options Button

Definitely true about the UI. But I did notice that the pmset command seems to have it turned on. Could definitely be some cruft in how that command works, but might be worth checking on.

# pmset -g    
System-wide power settings:
 SleepDisabled		0
Currently in use:
 standby              0
 Sleep On Power Button 1
 autorestart          1
 powernap             1
 networkoversleep     0
 disksleep            10
 sleep                0 (sleep prevented by powerd, nsurlsessiond, nsurlsessiond, screensharingd)
 ttyskeepawake        1
 displaysleep         10
 tcpkeepalive         1
 lowpowermode         0
 womp                 1
1 Like