Custom menu shortcut key: strange behaviour

Fm Version:
OS Version: Mac OS Monterey 12.5
Mac Mini M1
Keyboard: AZERTY (French)

When I define a shortcut key in my custom menu I'm seeing something strange:

I choose CMD-ALT-2 (from the numeric keypad) as shortcut
but in my Filemaker menu i'm seeing CMD-ALT-é
For QWERTY users: é is the key underneath the 2 (lowercase row) of the main keyboard.
Since when it is not allowed to use the numeric keypad for shortcuts?
Is this new or has it always been?
Any solutions?

I've never tried to use the numeric keypad for shortcuts. Do you get the same result if you use the key for 2 on the main keys?

I can't use the numbers on the main keys. Filemaker refuses. Checked if they are used by macOS but that is not the case.
It's not that important but I'm curious why I can't. Numbers as shortcuts can be handy sometimes.

CMD + 1…9 and 0 are used in FM for the first 10 Scripts that are activated for use in the script menu. But if you use CMD in conjunction with OPTION or SHIFT, I think it should work. What about CONTROL + 1…0? Without CMD.

Please try it, with me it does not. I can't use any combination with the number keys (macOS)

OK - I'll try it this evening and then give feedback.

Regards from Germany

The definition:

The result:

Screenshot 2022-08-01 at 11.42.19

I see. I'll try with German localization and with French.

I have tried now with my system language set to Français (Belgique) and with German.
No strange behaviour. Everything worked fine. Defining the shortcut with the 9 from numeric keypad or the main key did not make a difference. Using the shortcut worked also with both keys.

Menu allemand

As keyboard I am using a Logitech MX KEYS for Mac.

Here's my test file: (83,8 KB)

MacOS now has a feature to localize the shortcuts.
That is something developers can configure, so I assume a future FileMaker Pro will tell the OS to not localize them.