Filemaker and Javascript (OnMouseOver)

Based on this tweet from Osamu Noda ,I tried duplicating it in windows 10 using FM 19 but it doesn't work.

Attached is a similar file where I have a JS onmouseover event , the text turns red on mouseover but the filemaker script is not triggered. Sample file attached.
request someone to take a look at the file. Thanks.
Maybe a windows thing ?

HoverTest.fmp12 (212 KB)

Hello @kevinD

I am not currently at a machine which is current enough to run v.19, but nonetheless, I did see something that might be worth checking in the code in your uploaded file:

You have FileMaker.PerformScript spelled with a lower case 'm', i.e.:


I would suggest checking that detail. JavaScript is case-sensitive, and, unless this feature was specifically implemented with case-insensitivity in mind, I would expect the difference of that one letter to make a difference in whether the code works, or not.



Addendum: Just a note that there is also a check box in the webviewer configuration which I believe must be checked off in order for the JS to use FileMaker.PerformScript. That seems like it might be an easy item to overlook. Since I am only running v.18 on this machine, I am not able to verify whether or not you checked that box...


Thanks steve_ssh.
Tried that and it does'nt work. The documentation requires FileMaker - you are right.
The box in the web viewer to allow javascript is checked.

1 Like

I have sent Sam Oda an invitation to join the fmsoup. Would be great to meet him here.


Hi, Benjamin! Long time no see!


Hi, KevinD! I just tested your file in Windows. (changing your code Filemaker to FileMaker) It works.

1 Like

A warm welcome from all of us!
Iā€˜m glad you joined in.



Hi @sam_oda ! Great to see you here!

1 Like

Hi @steve_ssh, nice to see you again! :grinning:

1 Like

Thanks sam_oda. After a bit of fiddling it worked.
Apart from the spelling error, not sure what else was wrong. But now its fine.
thanks for trying it out and confirming it works on windows.

I would like to mark steve_ssh as answer. How can I do that?

1 Like

see how it is done by reading this post (link to specifi post in thread): Design Question - #9 by Bobino

Sorry not working for me.
When I expand the "three dots" below is what I get. See screen shot snippet.

Hi @kevinD ,

I moved this topic to the ER channel. In this channel, I expect you to now see this feature. Can you try again?

1 Like

Yes, I marked it as solution.
Thanks for your efforts.
best - Kevin