FMS 19.3.1 Linux odata-log

Hi guys,

did anybody have an issue with the odata log in the FMS admin-console on Linux Ubuntu 18.04 LTS server not showing timestamps?
Tested with remote console via Chrome and Safari from macOS 10.15.7.

I turned on odata, set up a file with an account with odata priviliges enabled. The communication between my weatherstation, my Node-Red server and the FM file works really nice. Every five minutes data from a bunch of sensors is beeing pushed into the hosted file.

If I look into the admin-console on protocols and turn the fmodata.log on, these actions are shown - but without a timestamp. If I download these entries I get them with timestamps included as expected.

The timezone is set to Europe/Berlin (CEST) via timedatectl on the Ubuntu terminal.

If I activate the new interactive protocol view I have the choice between event.log, access.log and fmodata.log. At least two of those have to be active. If I include fmodata in any combination, there are no entries of this type shown in the listing. The access.log entries show the odata connections but that's all.

Set up:
intel NUC i5 512GB NVMe SSD, 32GB RAM
Proxmox VE v.7
- VM with Ubuntu 18.04 LTS server

Anybody with any idea?

Just curious...did you set up FMS on a local Ubuntu instance, say, on VMFusion or similar? I'm wondering how SSL works in that case.
If a VM setup is a good way to go, I'm considering doing what you did and removing my FMS on AWS (and save $20/month). Thanks.

Hi Oliver,

last year I installed CentOS for my FMS 19.1/.2 directly on the NUC which was OK. Then the change was announced and I talked to some collegues about vitualizing the next Linux for FMS. Somebody pointed me to Proxmox. Proxmox is an open source project the gives KVM and QUEMU a GUI. It is based on Debian 10 and only has a small footprint on the system managing the VMs.

At the moment I am quite happy with the setup. You can park your instances, test different versions... I have set up a Univention server on a parallel VM on the same machine without any hazzle.

For the FMS I have installed network-manager and set up IPv4 settings with fixed internal IP and DHCP turned off on the Ubuntu system.

The DNS entry matching the FMS servers name is entered into the etc/hosts file on my internal DNS server. Thus the local host can be reached via name, not only via IP.

The FMS' CStore directory holds the same files you find on any other FMS.
/opt/Filemaker/Filemaker Server/CStore
I replaced serverRequest.pem with the one I use for my wildcard certificate. Afterwards I could import the certificate with the admin-console. The lock is green now in the local network :slight_smile:

But VM does not have to be the sole solution in the local environment. I remember having set up FMS 5.5 on SuseLinux on a small business Dell PC. That one ran in a corner in the customers office for 20+ user for years. So a dedicated computer might be another alternative to think about.


So, if my SSL site where FMS is right now on AWS is "" and I have a certificate for that, is it possible to set that same certificate on the local (in my case VMFUSION) FM setup?
It sounds like you're more of a network expert than I am, but I'm installing 18.04.5 as I write this and will experiment.
@WimDecorte 's excellent web tutorial on this topic is immensely helpful also.

Reuising the SSL-Cert should be no problem. You will have to generate a new server request (CSR) from the local FMS and get a reissued Cert from your CA. If the name of the FMS is the same as the one on AWS that will work.

(Got FMS installed on ubuntu server.)

1 Like