PDF Interactive Container crashes on mac

There is a long-lasting history about problems with interactive containers displaying PDFs on mac, but I was under the impression this had been addressed. It just happened to me with FMPA18 on Mojave.

Not a context where I have extra time available (budget-wise) for stuff that should work not to work. Any cues on what I should be looking into. The default viewer is Preview, Acrobat is running the latest version.

Thanks for any help you can share.

The part of the post mentioned by @FMSundae that made this work for me is

“Remove the following two Adobe plug-ins:
[Hard Disk] -> Library -> Internet Plug-Ins -> AdobePDFViewer.plugin
[Hard Disk] -> Library -> Internet Plug-Ins -> AdobePDFViewerNPAPI.plugin

Relaunch FileMaker Pro, and access the hosted file. FileMaker Pro should now use Preview controls for the PDF inside the interactive Container field.”

1 Like

No issue with no Acrobat installed.

Followed this article today: removing 2 files from Library folder, and it worked!

I appear to have had a similar issue. Mac 10.13 FM 18.0.3. FileMaker quit out whenever I tried to Insert a PDF into an interactive container, in a vanilla file, plus would not display contents other than file icon.

Hope this helps.


It worked! Thank you so much. It’s the kind of thing that will make me go nuts, looking left and right for what may be involved.

1 Like

thank you for hinting again at those files

crashlog after FileMaker crashed (FMPA 16 running agains FMS 16 both on macOS 12)
where I wanted to open a window and load a pdf from a container field into a global stored container field.


Thread 22 Crashed:
0 libobjc.A.dylib 0x00007fffea26305d objc_msgSend + 29
1 com.adobe.acrobat.pdfviewer 0x00000001209f7aa3 0x1209e0000 + 96931
2 com.adobe.acrobat.pdfviewer 0x00000001209f84d3 0x1209e0000 + 99539
3 com.adobe.acrobat.pdfviewer 0x00000001209e2380 0x1209e0000 + 9088
4 com.adobe.acrobat.pdfviewer 0x00000001209e2224 0x1209e0000 + 8740
5 com.apple.Foundation 0x00007fffd6dcc11d NSThread__start + 1243
6 libsystem_pthread.dylib 0x00007fffeadc493b _pthread_body + 180
7 libsystem_pthread.dylib 0x00007fffeadc4887 _pthread_start + 286
8 libsystem_pthread.dylib 0x00007fffeadc408d thread_start + 13

Thread 23:: com.apple.appkit-heartbeat
0 libsystem_kernel.dylib 0x00007fffeacd9f46 __semwait_signal + 10
1 libsystem_c.dylib 0x00007fffeac60b72 nanosleep + 199
2 libsystem_c.dylib 0x00007fffeac60a66 usleep + 54
3 com.apple.AppKit 0x00007fffd3164af6 -[NSUIHeartBeat _heartBeatThread:] + 2696
4 com.apple.Foundation 0x00007fffd6dcc11d NSThread__start + 1243
5 libsystem_pthread.dylib 0x00007fffeadc493b _pthread_body + 180
6 libsystem_pthread.dylib 0x00007fffeadc4887 _pthread_start + 286
7 libsystem_pthread.dylib 0x00007fffeadc408d thread_start + 13

Thread 22 crashed with X86 Thread State (64-bit):
rax: 0x000070000f157c08 rbx: 0x000070000f157bf8 rcx: 0xe360dfb94cb60058 rdx: 0x0000000000000000
rdi: 0x00007fffd536093b rsi: 0x00007fffd3af4d7f rbp: 0x000070000f157b70 rsp: 0x000070000f157768
r8: 0x0000000000000000 r9: 0x0000000000000600 r10: 0x0000000000000000 r11: 0x00007fffd3af4d7f
r12: 0x00006000006c52b0 r13: 0x00006000006c6f20 r14: 0x00007fffea263001 r15: 0x00007fffd3ac1bb7
rip: 0x00007fffea26305d rfl: 0x0000000000010297 cr2: 0x0000000000000018


removing the aforemenshioned files from the library-folder did the trick
thanks you

1 Like