Web Viewer Loading With Unsaved Scripts - FMP 19 for Windows Crashing

I’ve now managed to replicate this reliably, but still have some work to do. Has anyone else seen FMP19 in Windows unexpectedly quit if they have an unsaved script open, then navigate to a layout that populates a web viewer?

We are using a field containing JSON with the new JavaScript functions to populate the web viewer, I haven’t as yet tried a web viewer without JavaScript but have removed all plugins and the problem persists.

The layout loads, the fields can be viewed and the web viewer starts to load before the “You have 1 script(s) open with unsaved changes. Do you want to save these changes before performing this operation? message appears. So far, it doesn’t matter if the ‘Don’t Save’, ‘Cancel’ or ‘Save All’ button is clicked, it pauses and then FMP exits. This can be replicated each time.

I will report this on the community website, but first wondered if anyone else has seen this. By the way, this is Windows only, I’ve just tried in on my Mac and within this initial test it behaved fine.

Many thanks

1 Like

This still happens in v19.1.2